summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-02 15:24:17 +0800
committerUniversebenzene2018-02-02 15:24:17 +0800
commita126523920f8fe53851b6fe7ed2b8a42ed21a068 (patch)
tree13084b5c63376f227169c115aa8bfac23c2ecf9e
downloadaur-a126523920f8fe53851b6fe7ed2b8a42ed21a068.tar.gz
Initial import 1.0.5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcc9ecfa2426
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 2 06:53:28 UTC 2018
+pkgbase = python2-astroscrappy
+ pkgdesc = Speedy Cosmic Ray Annihilation Package in Python
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/astropy/astroscrappy
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = python2-numpy
+ depends = python2-astropy
+ depends = cython>=0.21
+ source = https://files.pythonhosted.org/packages/source/a/astroscrappy/astroscrappy-1.0.5.tar.gz
+ md5sums = e7ec5d829191226e6092b08e1d8f4cd4
+
+pkgname = python2-astroscrappy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baf2cb23b14d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python2-astroscrappy
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Speedy Cosmic Ray Annihilation Package in Python"
+arch=('i686' 'x86_64')
+url="https://github.com/astropy/astroscrappy"
+license=('BSD')
+depends=('python2' 'python2-numpy' 'python2-astropy' 'cython>=0.21')
+source=("https://files.pythonhosted.org/packages/source/a/astroscrappy/astroscrappy-${pkgver}.tar.gz")
+md5sums=('e7ec5d829191226e6092b08e1d8f4cd4')
+
+package() {
+ cd ${srcdir}/astroscrappy-${pkgver}
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+}