summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-26 17:05:27 +0200
committerPellegrino Prevete2023-06-26 17:05:27 +0200
commit1e0a542cb428501c5dbe1a1e3773ae81ca20f410 (patch)
tree10a598e4cc3fceb5e4b90735a9efa2fcca619f14
parentfe421812c9d0fe1d13c36ef0df52359594222f9a (diff)
downloadaur-1e0a542cb428501c5dbe1a1e3773ae81ca20f410.tar.gz
easier to read
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD85
-rw-r--r--audit-3.0.8-config_paths.patch36
3 files changed, 106 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb2c3d260eda..55b2ab962bec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,37 @@
pkgbase = python2-audit
pkgdesc = Userspace components of the audit framework
- pkgver = 2.8.5
- pkgrel = 9
+ pkgver = 3.0.8
+ pkgrel = 1
url = https://people.redhat.com/sgrubb/audit
arch = x86_64
- license = GPL
+ license = GPL2
+ license = LGPL2.1
+ makedepends = glibc
makedepends = krb5
makedepends = libcap-ng
makedepends = libldap
- makedepends = swig
makedepends = linux-headers
makedepends = python2
+ makedepends = swig
+ options = debug
options = emptydirs
- source = python2-audit-2.8.5.tar.gz::https://people.redhat.com/sgrubb/audit/audit-2.8.5.tar.gz
- source = fno-common.patch
- source = gcc10.patch
- sha512sums = 7d416aaa21c1a167f8e911ca82aecbaba804424f3243f505066c43ecc4a62a34feb2c27555e99d3268608404793dccca0f828c63670e3aa816016fb493f8174a
- sha512sums = 4d491ef7dacb23049993a87be7ddbb89657472df3082bb43f68b867d88804cdd74a543a7e0be4d9ad2554ee76def6982ee14a69224a2f4c67f66ab550239e6fe
- sha512sums = 78e32c05b6896d37bacf0938954fbce7486a528dabd55421f1715438fe489171f9157059050abdcb3f673258aa28b4a11f643ddb7824f3499a195dbbe634f101
+ source = https://people.redhat.com/sgrubb/audit/audit-3.0.8.tar.gz
+ source = audit-3.0.8-config_paths.patch
+ sha512sums = 8379bf425d68381d182300e628e42de8460d2f3e15b2395e10880f94b9989656852a50a9bece75b632ec8a04c40c9e666ff4c9d6b25ace3a8f50d2011506afab
+ sha512sums = bc699123f810abcf9300728bf61d7fcfcc83677b75fbeb713fb24cc11b2f9edf687661aab70766acde7c3c41c6a62f8e0a54cdfb49d1c7ce2246b67fbe3feec5
+ b2sums = 38a35a7540e608127cfc54a2de2cb12df8c29e778799ca53318824c84565a67b7ea131f9bba455fa469ce9139a27908738f571a6e383ce9a3274f70c09d27ec7
+ b2sums = 50be1b4f76ace20d8d14b4c57a9bb69daa3da35fd654aca8730bc287682fe38f1c1917b37469fb087daf9f309ffc15cca15f54166ece0a055f540c2604778fc6
pkgname = python2-audit
pkgdesc = Userspace components of the audit framework (python 2.X bindings)
depends = python2
depends = audit
-
+ backup = etc/libaudit.conf
+ backup = etc/audit/audit-stop.rules
+ backup = etc/audit/auditd.conf
+ backup = etc/audit/audisp-remote.conf
+ backup = etc/audit/zos-remote.conf
+ backup = etc/audit/plugins.d/af_unix.conf
+ backup = etc/audit/plugins.d/au-remote.conf
+ backup = etc/audit/plugins.d/audispd-zos-remote.conf
+ backup = etc/audit/plugins.d/syslog.conf
diff --git a/PKGBUILD b/PKGBUILD
index c401ab9abcbc..dba18b08d6ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,63 +8,74 @@
# Contributor: Connor Behan <connor.behan@gmail.com>
# Contributor: henning mueller <henning@orgizm.net>
-_pkgbase=audit
-pkgbase="python2-${_pkgbase}"
-pkgname="python2-$_pkgbase"
+_py="python2"
+_pkg=audit
+pkgname="${_py}-${_pkg}"
pkgver=3.0.8
pkgrel=1
-pkgdesc='Userspace components of the audit framework'
-url='https://people.redhat.com/sgrubb/audit'
+pkgdesc="Userspace components of the ${_pkg} framework"
+url="https://people.redhat.com/sgrubb/${_pkg}"
arch=(x86_64)
-makedepends=(glibc krb5 libcap-ng libldap linux-headers python2 swig )
+makedepends=(
+ glibc
+ krb5
+ libcap-ng
+ libldap
+ linux-headers
+ "${_py}"
+ swig )
license=(GPL2 LGPL2.1)
options=(debug emptydirs)
-source=("https://people.redhat.com/sgrubb/${_pkgbase}/${_pkgbase}-${pkgver}.tar.gz"
- $_pkgbase-3.0.8-config_paths.patch)
-sha512sums=('8379bf425d68381d182300e628e42de8460d2f3e15b2395e10880f94b9989656852a50a9bece75b632ec8a04c40c9e666ff4c9d6b25ace3a8f50d2011506afab'
- 'bc699123f810abcf9300728bf61d7fcfcc83677b75fbeb713fb24cc11b2f9edf687661aab70766acde7c3c41c6a62f8e0a54cdfb49d1c7ce2246b67fbe3feec5')
-b2sums=('38a35a7540e608127cfc54a2de2cb12df8c29e778799ca53318824c84565a67b7ea131f9bba455fa469ce9139a27908738f571a6e383ce9a3274f70c09d27ec7'
- '50be1b4f76ace20d8d14b4c57a9bb69daa3da35fd654aca8730bc287682fe38f1c1917b37469fb087daf9f309ffc15cca15f54166ece0a055f540c2604778fc6')
+source=("${url}/${_pkg}-${pkgver}.tar.gz"
+ "${_pkg}-${pkgver}-config_paths.patch")
+sha512sums=(
+ '8379bf425d68381d182300e628e42de8460d2f3e15b2395e10880f94b9989656852a50a9bece75b632ec8a04c40c9e666ff4c9d6b25ace3a8f50d2011506afab'
+ 'bc699123f810abcf9300728bf61d7fcfcc83677b75fbeb713fb24cc11b2f9edf687661aab70766acde7c3c41c6a62f8e0a54cdfb49d1c7ce2246b67fbe3feec5')
+b2sums=(
+ '38a35a7540e608127cfc54a2de2cb12df8c29e778799ca53318824c84565a67b7ea131f9bba455fa469ce9139a27908738f571a6e383ce9a3274f70c09d27ec7'
+ '50be1b4f76ace20d8d14b4c57a9bb69daa3da35fd654aca8730bc287682fe38f1c1917b37469fb087daf9f309ffc15cca15f54166ece0a055f540c2604778fc6')
prepare() {
# replace the use of /sbin with /usr/bin in configs
- patch -Np1 -d $_pkgbase-$pkgver -i ../$_pkgbase-3.0.8-config_paths.patch
+ patch -Np1 -d "${_pkg}-${pkgver}" -i "../${_pkg}-${pkgver}-config_paths.patch"
}
build() {
- cd $_pkgbase-$pkgver
- export PYTHON=/usr/bin/python2
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib/audit \
- --enable-gssapi-krb5=yes \
- --enable-systemd=yes \
- --with-libcap-ng=yes \
- --without-python3
+ local _configure_opts=(
+ --prefix=/usr
+ --sbindir=/usr/bin
+ --sysconfdir=/etc
+ "--libexecdir=/usr/lib/${_pkg}"
+ --enable-gssapi-krb5=yes
+ --enable-systemd=yes
+ --with-libcap-ng=yes
+ --without-python3)
+
+ cd "${_pkg}-${pkgver}"
+ export PYTHON="/usr/bin/${_py}"
+ ./configure "${_configure_opts[@]}"
# prevent excessive overlinking due to libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
- [ -n "${SOURCE_DATE_EPOCH}" ] && touch -h -d @$SOURCE_DATE_EPOCH bindings/swig/python/audit.py
+ [ -n "${SOURCE_DATE_EPOCH}" ] && touch -h -d @$SOURCE_DATE_EPOCH "bindings/swig/python/${_pkg}.py"
}
package_python2-audit() {
- depends=('python2' "${_pkgbase}")
+ depends=("${_py}" "${_pkg}")
backup=(
- etc/libaudit.conf
- etc/audit/audit-stop.rules
- etc/audit/auditd.conf
- etc/audit/audisp-remote.conf
- etc/audit/zos-remote.conf
- etc/audit/plugins.d/af_unix.conf
- etc/audit/plugins.d/au-remote.conf
- etc/audit/plugins.d/audispd-zos-remote.conf
- etc/audit/plugins.d/syslog.conf
+ "etc/lib${_pkg}.conf"
+ "etc/${_pkg}/${_pkg}-stop.rules"
+ "etc/${_pkg}/${_pkg}d.conf"
+ "etc/${_pkg}/audisp-remote.conf"
+ "etc/${_pkg}/zos-remote.conf"
+ "etc/${_pkg}/plugins.d/af_unix.conf"
+ "etc/${_pkg}/plugins.d/au-remote.conf"
+ "etc/${_pkg}/plugins.d/audispd-zos-remote.conf"
+ "etc/${_pkg}/plugins.d/syslog.conf"
)
pkgdesc+=' (python 2.X bindings)'
- export PYTHON=/usr/bin/python2
- cd audit-${pkgver}
+ export PYTHON="/usr/bin/${_py}"
+ cd "${_pkg}-${pkgver}"
make -C bindings DESTDIR="${pkgdir}" INSTALL='install -p' install
rm -rf ${pkgdir}/usr/lib/python3*
rm -rf ${pkgdir}/usr/lib/golang
diff --git a/audit-3.0.8-config_paths.patch b/audit-3.0.8-config_paths.patch
new file mode 100644
index 000000000000..24fd8b3ddc12
--- /dev/null
+++ b/audit-3.0.8-config_paths.patch
@@ -0,0 +1,36 @@
+diff -ruN a/audisp/plugins/remote/au-remote.conf b/audisp/plugins/remote/au-remote.conf
+--- a/audisp/plugins/remote/au-remote.conf 2022-03-29 22:52:34.000000000 +0200
++++ b/audisp/plugins/remote/au-remote.conf 2022-04-21 11:11:55.685862988 +0200
+@@ -5,7 +5,7 @@
+
+ active = no
+ direction = out
+-path = /sbin/audisp-remote
++path = /usr/bin/audisp-remote
+ type = always
+ #args =
+ format = string
+diff -ruN a/audisp/plugins/syslog/syslog.conf b/audisp/plugins/syslog/syslog.conf
+--- a/audisp/plugins/syslog/syslog.conf 2022-03-29 22:52:34.000000000 +0200
++++ b/audisp/plugins/syslog/syslog.conf 2022-04-21 11:12:54.669352650 +0200
+@@ -8,7 +8,7 @@
+
+ active = no
+ direction = out
+-path = /sbin/audisp-syslog
++path = /usr/bin/audisp-syslog
+ type = always
+ args = LOG_INFO
+ format = string
+diff -ruN a/audisp/plugins/zos-remote/audispd-zos-remote.conf b/audisp/plugins/zos-remote/audispd-zos-remote.conf
+--- a/audisp/plugins/zos-remote/audispd-zos-remote.conf 2022-03-29 22:52:34.000000000 +0200
++++ b/audisp/plugins/zos-remote/audispd-zos-remote.conf 2022-04-21 11:12:26.419277793 +0200
+@@ -8,7 +8,7 @@
+
+ active = no
+ direction = out
+-path = /sbin/audispd-zos-remote
++path = /usr/bin/audispd-zos-remote
+ type = always
+ args = /etc/audit/zos-remote.conf
+ format = string