summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-06-15 23:57:28 +0000
committerPellegrino Prevete2022-06-15 23:57:28 +0000
commitfe421812c9d0fe1d13c36ef0df52359594222f9a (patch)
tree0def2085609f7c017bc8b903bbc00057c7b657d6
parenta41a95fc507b92c2ee0214f8206e7d09195b7faf (diff)
downloadaur-fe421812c9d0fe1d13c36ef0df52359594222f9a.tar.gz
try update to 3.0.8
-rw-r--r--PKGBUILD63
1 files changed, 41 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a58a2a23412..c401ab9abcbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,38 @@
-# Mantainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: <kang@insecure.ws>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Connor Behan <connor.behan@gmail.com>
+# Contributor: henning mueller <henning@orgizm.net>
-pkgbase='python2-audit'
-pkgname='python2-audit'
-pkgver=2.8.5
-pkgrel=9
+_pkgbase=audit
+pkgbase="python2-${_pkgbase}"
+pkgname="python2-$_pkgbase"
+pkgver=3.0.8
+pkgrel=1
pkgdesc='Userspace components of the audit framework'
url='https://people.redhat.com/sgrubb/audit'
-arch=('x86_64')
-makedepends=('krb5' 'libcap-ng' 'libldap' 'swig' 'linux-headers' 'python2')
-license=('GPL')
-options=('emptydirs')
-source=(python2-audit-${pkgver}.tar.gz::https://people.redhat.com/sgrubb/audit/audit-${pkgver}.tar.gz
-'fno-common.patch'
-'gcc10.patch')
-sha512sums=('7d416aaa21c1a167f8e911ca82aecbaba804424f3243f505066c43ecc4a62a34feb2c27555e99d3268608404793dccca0f828c63670e3aa816016fb493f8174a'
-'4d491ef7dacb23049993a87be7ddbb89657472df3082bb43f68b867d88804cdd74a543a7e0be4d9ad2554ee76def6982ee14a69224a2f4c67f66ab550239e6fe'
-'78e32c05b6896d37bacf0938954fbce7486a528dabd55421f1715438fe489171f9157059050abdcb3f673258aa28b4a11f643ddb7824f3499a195dbbe634f101')
+arch=(x86_64)
+makedepends=(glibc krb5 libcap-ng libldap linux-headers python2 swig )
+license=(GPL2 LGPL2.1)
+options=(debug emptydirs)
+source=("https://people.redhat.com/sgrubb/${_pkgbase}/${_pkgbase}-${pkgver}.tar.gz"
+ $_pkgbase-3.0.8-config_paths.patch)
+sha512sums=('8379bf425d68381d182300e628e42de8460d2f3e15b2395e10880f94b9989656852a50a9bece75b632ec8a04c40c9e666ff4c9d6b25ace3a8f50d2011506afab'
+ 'bc699123f810abcf9300728bf61d7fcfcc83677b75fbeb713fb24cc11b2f9edf687661aab70766acde7c3c41c6a62f8e0a54cdfb49d1c7ce2246b67fbe3feec5')
+b2sums=('38a35a7540e608127cfc54a2de2cb12df8c29e778799ca53318824c84565a67b7ea131f9bba455fa469ce9139a27908738f571a6e383ce9a3274f70c09d27ec7'
+ '50be1b4f76ace20d8d14b4c57a9bb69daa3da35fd654aca8730bc287682fe38f1c1917b37469fb087daf9f309ffc15cca15f54166ece0a055f540c2604778fc6')
prepare() {
- cd audit-${pkgver}
- sed 's|/var/run/auditd.pid|/run/auditd.pid|' -i init.d/auditd.service
-
- # https://bugs.gentoo.org/show_bug.cgi\?id\=706734
- patch --forward --strip=1 --input="${srcdir}/fno-common.patch"
+ # replace the use of /sbin with /usr/bin in configs
+ patch -Np1 -d $_pkgbase-$pkgver -i ../$_pkgbase-3.0.8-config_paths.patch
}
build() {
- cd audit-${pkgver}
+ cd $_pkgbase-$pkgver
export PYTHON=/usr/bin/python2
./configure \
--prefix=/usr \
@@ -37,12 +43,25 @@ build() {
--enable-systemd=yes \
--with-libcap-ng=yes \
--without-python3
+ # prevent excessive overlinking due to libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
[ -n "${SOURCE_DATE_EPOCH}" ] && touch -h -d @$SOURCE_DATE_EPOCH bindings/swig/python/audit.py
}
package_python2-audit() {
- depends=('python2' 'audit')
+ depends=('python2' "${_pkgbase}")
+ backup=(
+ etc/libaudit.conf
+ etc/audit/audit-stop.rules
+ etc/audit/auditd.conf
+ etc/audit/audisp-remote.conf
+ etc/audit/zos-remote.conf
+ etc/audit/plugins.d/af_unix.conf
+ etc/audit/plugins.d/au-remote.conf
+ etc/audit/plugins.d/audispd-zos-remote.conf
+ etc/audit/plugins.d/syslog.conf
+ )
pkgdesc+=' (python 2.X bindings)'
export PYTHON=/usr/bin/python2
cd audit-${pkgver}