summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-03-23 16:50:05 +0800
committerChih-Hsuan Yen2019-03-23 17:05:33 +0800
commitded5b8155ff52cc84c7997e3c7e19c253072e254 (patch)
tree43af428bd61be3dad76d8db555daa992c801f15f
parent2b91ccc38b694a19904c7895a9e193d870e8234e (diff)
downloadaur-ded5b8155ff52cc84c7997e3c7e19c253072e254.tar.gz
Update to 19.3.2
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD51
-rw-r--r--skip-test-missing-serializers.patch34
3 files changed, 89 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 038bfda6394f..896ed18c1c1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,27 @@
pkgbase = python2-autobahn
- pkgdesc = Twisted-based WebSocket/WAMP client and server framework
- pkgver = 0.10.5
+ pkgdesc = Real-time framework for Web, Mobile & Internet of Things
+ pkgver = 19.3.2
pkgrel = 1
- url = http://autobahn.ws/python/
+ url = https://crossbar.io/autobahn/
arch = any
- license = Apache
+ license = MIT
+ checkdepends = python2-mock
+ checkdepends = python2-pytest
makedepends = python2-setuptools
- depends = python2
- depends = twisted
+ makedepends = python2-msgpack
+ makedepends = python2-pynacl
+ makedepends = python2-trollius
+ depends = python2-twisted
depends = python2-six
- source = https://pypi.python.org/packages/source/a/autobahn/autobahn-0.10.5.tar.gz
- md5sums = 75cbbead47bdac8ee606ca3ce9ee742e
+ depends = python2-txaio
+ depends = python2-trollius
+ depends = python2-wsaccel
+ optdepends = python2-msgpack: MsgPack serializer support
+ optdepends = python2-pynacl: WAMP-cryptosign support
+ source = https://pypi.io/packages/source/a/autobahn/autobahn-19.3.2.tar.gz
+ source = skip-test-missing-serializers.patch
+ sha256sums = 70a221d5e01923ea81457de04a3270ea2de376a759345ec4e8693db216c603a9
+ sha256sums = 2d4ec4300f98cddd13c3a4d70e6ae4934a98f17b04628cadfd18654172d04f92
pkgname = python2-autobahn
diff --git a/PKGBUILD b/PKGBUILD
index 5bc6421b662a..299b22ac3a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,47 @@
-# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+# Contributor: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
# Contributor: veox <veox at wemakethings dot net>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: Anatol Pomozov
pkgname=python2-autobahn
-pkgver=0.10.5
+pkgver=19.3.2
pkgrel=1
-pkgdesc="Twisted-based WebSocket/WAMP client and server framework"
-url="http://autobahn.ws/python/"
-arch=('any')
-license=('Apache')
-depends=('python2' 'twisted' 'python2-six')
-makedepends=('python2-setuptools')
-source=(https://pypi.python.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
-md5sums=('75cbbead47bdac8ee606ca3ce9ee742e')
+pkgdesc='Real-time framework for Web, Mobile & Internet of Things'
+arch=(any)
+url='https://crossbar.io/autobahn/'
+license=(MIT)
+depends=(python2-twisted python2-six python2-txaio python2-trollius python2-wsaccel)
+makedepends=(python2-setuptools python2-msgpack python2-pynacl python2-trollius)
+checkdepends=(python2-mock python2-pytest)
+optdepends=(
+ 'python2-msgpack: MsgPack serializer support'
+ 'python2-pynacl: WAMP-cryptosign support'
+)
+source=(https://pypi.io/packages/source/a/autobahn/autobahn-$pkgver.tar.gz
+ skip-test-missing-serializers.patch)
+sha256sums=('70a221d5e01923ea81457de04a3270ea2de376a759345ec4e8693db216c603a9'
+ '2d4ec4300f98cddd13c3a4d70e6ae4934a98f17b04628cadfd18654172d04f92')
+
+prepare() {
+ cd "$srcdir/autobahn-$pkgver"
+ patch -Np1 -i ../skip-test-missing-serializers.patch
+}
build() {
- cd "$srcdir/autobahn-${pkgver/_/-}"
+ cd "$srcdir/autobahn-$pkgver"
python2 setup.py build
}
-package() {
- cd "$srcdir/autobahn-${pkgver/_/-}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+check() {
+ cd "$srcdir/autobahn-$pkgver"
+ USE_TWISTED=1 PYTHONPATH=. pytest2 -v autobahn
+ USE_ASYNCIO=1 PYTHONPATH=. pytest2 -v autobahn
}
-# vim:set ft=sh ts=2 sw=2 et:
+package() {
+
+ cd "$srcdir/autobahn-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/skip-test-missing-serializers.patch b/skip-test-missing-serializers.patch
new file mode 100644
index 000000000000..f6150249ddc3
--- /dev/null
+++ b/skip-test-missing-serializers.patch
@@ -0,0 +1,34 @@
+diff --git a/autobahn/wamp/test/test_serializer.py b/autobahn/wamp/test/test_serializer.py
+index 8e47805c..117df18d 100644
+--- a/autobahn/wamp/test/test_serializer.py
++++ b/autobahn/wamp/test/test_serializer.py
+@@ -129,11 +129,17 @@ def create_serializers():
+ _serializers.append(serializer.MsgPackSerializer())
+ _serializers.append(serializer.MsgPackSerializer(batched=True))
+
+- _serializers.append(serializer.CBORSerializer())
+- _serializers.append(serializer.CBORSerializer(batched=True))
++ try:
++ _serializers.append(serializer.CBORSerializer())
++ _serializers.append(serializer.CBORSerializer(batched=True))
++ except AttributeError:
++ pass
+
+- _serializers.append(serializer.UBJSONSerializer())
+- _serializers.append(serializer.UBJSONSerializer(batched=True))
++ try:
++ _serializers.append(serializer.UBJSONSerializer())
++ _serializers.append(serializer.UBJSONSerializer(batched=True))
++ except AttributeError:
++ pass
+
+ # FIXME: implement full FlatBuffers serializer for WAMP
+ if six.PY3:
+@@ -146,6 +152,7 @@ def create_serializers():
+
+
+ @unittest.skipIf(not six.PY3, 'WAMP-FlatBuffers currently only supports Python 3')
++@unittest.skipIf(not hasattr(serializer, 'FlatBuffersSerializer'), 'FlatBuffers support missing')
+ class TestFlatBuffersSerializer(unittest.TestCase):
+
+ def test_basic(self):