summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-07-17 13:56:17 +0100
committerDaichi Shinozaki2015-07-17 13:56:17 +0100
commitf12a6dbaa17ab400022761aaeb5b53767de274cd (patch)
tree112d18ffca6c0c012c7134bf9256aaecbc48609c
downloadaur-f12a6dbaa17ab400022761aaeb5b53767de274cd.tar.gz
Adopted & bump version to 0.10.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef1a64d18ac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-autobahn
+ pkgdesc = Twisted-based WebSocket/WAMP client and server framework
+ pkgver = 0.10.4
+ pkgrel = 1
+ url = http://autobahn.ws/python/
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ depends = twisted
+ depends = python2-six
+ source = https://pypi.python.org/packages/source/a/autobahn/autobahn-0.10.4.tar.gz
+ md5sums = 4ae22413ee9ba8f6692e80e171b68777
+
+pkgname = python2-autobahn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca4cb2cabfd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+# Contributor: veox <veox at wemakethings dot net>
+
+pkgname=python2-autobahn
+pkgver=0.10.4
+pkgrel=1
+pkgdesc="Twisted-based WebSocket/WAMP client and server framework"
+url="http://autobahn.ws/python/"
+arch=('any')
+license=('Apache')
+depends=('python2' 'twisted' 'python2-six')
+makedepends=('python2-setuptools')
+source=(https://pypi.python.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
+md5sums=('4ae22413ee9ba8f6692e80e171b68777')
+
+build() {
+ cd "$srcdir/autobahn-${pkgver/_/-}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/autobahn-${pkgver/_/-}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ft=sh ts=2 sw=2 et: