summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-08-23 09:13:25 -0400
committerChris Severance2018-08-23 09:13:25 -0400
commit1c8fc44014ef09418e83b792239ef836bdde3073 (patch)
tree2dac914a15e62ee8bf72e1297dabd00b9e7349e8
parent53f619f59aafbb1d17d54f3f158608241217bdff (diff)
downloadaur-1c8fc44014ef09418e83b792239ef836bdde3073.tar.gz
Update to 1.15.84
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ec1fba76eff..7c88f0074eff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 26 16:25:35 UTC 2018
+# Thu Aug 23 13:13:25 UTC 2018
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.15.28
+ pkgver = 1.15.84
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -11,7 +11,7 @@ pkgbase = python2-aws-cli
makedepends = python2-distribute
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.10.28
+ depends = python2-botocore>=1.10.83
depends = python2-colorama>=0.2.5
depends = python2-rsa>=3.2
depends = python2-rsa<=3.5.0
@@ -21,10 +21,8 @@ pkgbase = python2-aws-cli
depends = python2-dateutil>=2.1
depends = python2-dateutil<3.0.0
depends = python2-jmespath>=0.7.1
- depends = python2-tox>=2.3.1
- depends = python2-tox<3.0.0
depends = python2-yaml>=3.10
- depends = python2-yaml<=3.12
+ depends = python2-yaml<=3.13
depends = python2-nose>=1.3.7
depends = python2-mock>=1.3.0
depends = python2-docutils>=0.10
@@ -34,11 +32,11 @@ pkgbase = python2-aws-cli
depends = python2-futures
options = !emptydirs
options = !strip
- source = aws-cli-1.15.28.tar.gz::https://github.com/aws/aws-cli/archive/1.15.28.tar.gz
- sha256sums = 3c2b3a6f5dc0c6eb336e4848009db73a3fa3cf9fe10203aef714bb521e8aae55
+ source = aws-cli-1.15.84.tar.gz::https://github.com/aws/aws-cli/archive/1.15.84.tar.gz
+ sha256sums = 0d37c61fbab169ea88e0c174e15e3df01b91341c894038a76ab33e3cb3e8c82b
pkgname = python2-aws-cli
- provides = aws-cli=1.15.28
+ provides = aws-cli=1.15.84
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = aws-cli
diff --git a/PKGBUILD b/PKGBUILD
index 2a3d8223403d..fe6330efa03b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,8 @@
# aws-cli & aws-cli-git
# python-botocore & python-botocore-git
+# TODO: put tox back into depends
+
# Use mcdiff to watch for changes
_fn_foobar() {
local _foobar="
@@ -26,18 +28,18 @@ colorama>=0.2.5,<=0.3.9
mock==1.3.0
rsa>=3.1.2,<=3.5.0
wheel==0.24.0
-PyYAML>=3.10,<=3.12
+PyYAML>=3.10,<=3.13
#setup.py
import awscli
-requires = ['botocore==1.10.28',
+requires = ['botocore==1.10.83',
'colorama>=0.2.5,<=0.3.9',
'docutils>=0.10',
'rsa>=3.1.2,<=3.5.0',
's3transfer>=0.1.12,<0.2.0',
- 'PyYAML>=3.10,<=3.12']
+ 'PyYAML>=3.10,<=3.13']
"
}
unset -f _fn_foobar
@@ -52,7 +54,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.15.28
+pkgver=1.15.84
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -61,7 +63,7 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.10.28" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.10.83" # AUR == would make upgrades from AUR impossible. See below.
"${_pyver}-colorama>=0.2.5" #,"<=0.3.7"} # COM requested by phw
"${_pyver}-rsa"{'>=3.2','<=3.5.0'}
"${_pyver}-s3transfer"{'>=0.1.12','<0.2.0'} # AUR
@@ -70,8 +72,8 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
"${_pyver}-wheel>=0.24.0" # AUR ==
"${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM
"${_pyver}-jmespath>=0.7.1" # AUR == is possible for repositories. Makes upgrades impossible in AUR.
- "${_pyver}-tox"{'>=2.3.1','<3.0.0'} # COM
- "${_pyver}-yaml"{">=3.10","<=3.12"} # COM
+ #"${_pyver}-tox"{'>=2.3.1','<3.0.0'} # COM
+ "${_pyver}-yaml"{">=3.10","<=3.13"} # COM
"${_pyver}-nose>=1.3.7" # COM ==
"${_pyver}-mock>=1.3.0" # COM ==
"${_pyver}-docutils>=0.10" # COM
@@ -87,7 +89,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('3c2b3a6f5dc0c6eb336e4848009db73a3fa3cf9fe10203aef714bb521e8aae55')
+sha256sums=('0d37c61fbab169ea88e0c174e15e3df01b91341c894038a76ab33e3cb3e8c82b')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"