summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-08-08 09:07:06 -0400
committerChris Severance2016-08-08 09:07:06 -0400
commit358dae7a3d14ce6d8c133d89f48d5905410e445e (patch)
tree3ab1875b8c8ee3335579351c77e9cd81b3f95446
parentb0eface7c4856d9150c82fccc525f838a9f85499 (diff)
downloadaur-358dae7a3d14ce6d8c133d89f48d5905410e445e.tar.gz
Update to 1.10.53
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63838c528df9..fc1c850e0920 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 25 21:44:10 UTC 2016
+# Mon Aug 8 13:04:41 UTC 2016
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.10.49
+ pkgver = 1.10.53
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -11,11 +11,12 @@ pkgbase = python2-aws-cli
makedepends = python2-distribute
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.4.39
+ depends = python2-botocore>=1.4.43
depends = python2-colorama>=0.2.5
depends = python2-rsa>=3.2
depends = python2-rsa<=3.5.0
- depends = python2-s3transfer>=0.0.1
+ depends = python2-s3transfer>=0.1.1
+ depends = python2-s3transfer<0.2.0
depends = python2-wheel>=0.24.0
depends = python2-jmespath>=0.7.1
depends = python2-tox>=2.3.1
@@ -31,11 +32,11 @@ pkgbase = python2-aws-cli
depends = python2-futures
options = !emptydirs
options = !strip
- source = aws-cli-1.10.49.tar.gz::https://github.com/aws/aws-cli/archive/1.10.49.tar.gz
- sha256sums = c6b0a6cd4c9c23930a87bbc53d0cea1092889df46c1834c6413ce1ba1a994757
+ source = aws-cli-1.10.53.tar.gz::https://github.com/aws/aws-cli/archive/1.10.53.tar.gz
+ sha256sums = aba33935f7e38f9de4afbcf8147d2d3807d718253179cd29edda92a5c06263fe
pkgname = python2-aws-cli
- provides = awscli=1.10.49
+ provides = awscli=1.10.53
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 9755c5a8b075..7c1ec1200abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,11 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.4.39',
+requires = ['botocore==1.4.43',
'colorama>=0.2.5,<=0.3.7',
'docutils>=0.10',
'rsa>=3.1.2,<=3.5.0',
- 's3transfer==0.0.1']
+ 's3transfer>=0.1.0,<0.2.0']
"
}
unset -f _fn_foobar
@@ -50,7 +50,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.10.49
+pkgver=1.10.53
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -59,10 +59,10 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.4.39" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.4.43" # AUR == would make upgrades from AUR impossible. See below.
"${_pyver}-colorama>=0.2.5" #,"<=0.3.7"} # COM requested by phw
"${_pyver}-rsa"{'>=3.2','<=3.5.0'}
- "${_pyver}-s3transfer>=0.0.1" # AUR
+ "${_pyver}-s3transfer"{'>=0.1.1','<0.2.0'} # AUR
### These are from python-botocore
"${_pyver}-wheel>=0.24.0" # AUR ==
@@ -84,7 +84,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('c6b0a6cd4c9c23930a87bbc53d0cea1092889df46c1834c6413ce1ba1a994757')
+sha256sums=('aba33935f7e38f9de4afbcf8147d2d3807d718253179cd29edda92a5c06263fe')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"