summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-03-17 14:58:24 -0400
committerChris Severance2016-03-17 14:58:24 -0400
commit57d0cc9c3bb3286e99c0d023d8cbb51e0b199160 (patch)
tree258f67d3b62eae6d764c14677a817f4b8ab49bf0
parent21e37b9a77e588de0ee2ad658950b1d97e40a02a (diff)
downloadaur-57d0cc9c3bb3286e99c0d023d8cbb51e0b199160.tar.gz
Update to 1.10.13
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92b37f2e8820..a714bfc0ad3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 13 20:21:10 UTC 2016
+# Thu Mar 17 18:58:24 UTC 2016
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.10.12
+ pkgver = 1.10.13
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -11,14 +11,15 @@ pkgbase = python2-aws-cli
makedepends = python2-distribute
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.4.3
+ depends = python2-botocore>=1.4.4
depends = python2-colorama>=0.2.5
depends = python2-rsa>=3.2
depends = python2-rsa<=3.3.0
depends = python2-s3transfer>=0.0.1
depends = python2-wheel>=0.24.0
depends = python2-jmespath>=0.7.1
- depends = python2-tox>=1.4
+ depends = python2-tox>=2.3.1
+ depends = python2-tox<3.0.0
depends = python2-dateutil>=2.1
depends = python2-dateutil<3.0.0
depends = python2-nose>=1.3.0
@@ -30,11 +31,11 @@ pkgbase = python2-aws-cli
depends = python2-futures
options = !emptydirs
options = !strip
- source = aws-cli-1.10.12.tar.gz::https://github.com/aws/aws-cli/archive/1.10.12.tar.gz
- sha256sums = b1eaab59898b366f9fc72c18a741945bb1adf9275e05f940c83f99b3548021cc
+ source = aws-cli-1.10.13.tar.gz::https://github.com/aws/aws-cli/archive/1.10.13.tar.gz
+ sha256sums = cd17f5e9fb0045e32f63969aa4e7acdda54598469ef411cb30a087c7e65f7eb9
pkgname = python2-aws-cli
- provides = awscli=1.10.12
+ provides = awscli=1.10.13
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 9127cd2408a4..5b65baf6fc08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ local _foobar="
#requirements-docs.txt
Sphinx==1.1.3
#requirements.txt
-tox==1.4
+tox>=2.3.1,<3.0.0
docutils>=0.10
# botocore and the awscli packages are typically developed
# in tandem, so we're requiring the latest develop
@@ -31,7 +31,7 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.4.3',
+requires = ['botocore==1.4.4',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
'rsa>=3.1.2,<=3.3.0',
@@ -50,7 +50,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.10.12
+pkgver=1.10.13
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -59,17 +59,17 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.4.3" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.4.4" # AUR == would make upgrades from AUR impossible. See below.
#"${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
"${_pyver}-colorama>=0.2.5" # COM requested by phw
#"${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.3.0"} # AUR
- "${_pyver}-rsa"{">=3.2","<=3.3.0"} # COM
+ "${_pyver}-rsa"{'>=3.2','<=3.3.0'} # COM
"${_pyver}-s3transfer>=0.0.1" # AUR
### These are from python-botocore
"${_pyver}-wheel>=0.24.0" # AUR ==
"${_pyver}-jmespath>=0.7.1" # AUR == is possible for repositories. Makes upgrades impossible in AUR.
- "${_pyver}-tox>=1.4" # COM == is possible because this is from a repository. Unfortunatley Arch isnt the primary dev environment for botocore/aws so our packages are likely to be newer.
+ "${_pyver}-tox"{'>=2.3.1','<3.0.0'} # COM
"${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM
"${_pyver}-nose>=1.3.0" # COM ==
"${_pyver}-mock>=1.3.0" # COM ==
@@ -77,7 +77,7 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
"${_pyver}-six>=1.1.0" # COM This is in the sources but I'm not sure where the version comes from.
# requirements-docs.txt
#"${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work.
- "${_pyver}-guzzle-sphinx-theme"{">=0.7.10","<0.8"}
+ "${_pyver}-guzzle-sphinx-theme"{'>=0.7.10','<0.8'}
)
if [ "${_pyver}" = 'python2' ]; then
_pydepends+=('python2-futures')
@@ -86,7 +86,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('b1eaab59898b366f9fc72c18a741945bb1adf9275e05f940c83f99b3548021cc')
+sha256sums=('cd17f5e9fb0045e32f63969aa4e7acdda54598469ef411cb30a087c7e65f7eb9')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"