summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-01-08 13:49:15 -0500
committerChris Severance2016-01-08 13:49:15 -0500
commit681b75b5fcf1e808d74c7980098b66709913866e (patch)
treeef3014e9737a209824734a0a0579453c780194a1
parent25bb9eaa4fbedb46755f809827976be1269b9589 (diff)
downloadaur-681b75b5fcf1e808d74c7980098b66709913866e.tar.gz
Update to 1.9.17
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ebe216dfaed..31589b0ec3db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 6 09:15:46 UTC 2016
+# Fri Jan 8 18:49:15 UTC 2016
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.9.16
+ pkgver = 1.9.17
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -11,7 +11,7 @@ pkgbase = python2-aws-cli
makedepends = python2-distribute
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.3.16
+ depends = python2-botocore>=1.3.17
depends = python2-colorama>=0.2.5
depends = python2-colorama<=0.3.3
depends = python2-rsa>=3.2
@@ -30,11 +30,11 @@ pkgbase = python2-aws-cli
depends = python2-guzzle-sphinx-theme<0.8
options = !emptydirs
options = !strip
- source = aws-cli-1.9.16.tar.gz::https://github.com/aws/aws-cli/archive/1.9.16.tar.gz
- sha256sums = 772f6d958d919246e09d0d4e5b66a356e9a3f9978e10cba870891564252743b1
+ source = aws-cli-1.9.17.tar.gz::https://github.com/aws/aws-cli/archive/1.9.17.tar.gz
+ sha256sums = 5593b19c2edc46d9750e9e8e71d73014f58ead318f7d76ebe0f9f54f7f595a3f
pkgname = python2-aws-cli
- provides = awscli=1.9.16
+ provides = awscli=1.9.17
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 5f23638923ae..d763f238a1d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,6 @@
# aws-cli & aws-cli-git
# python-botocore & python-botocore-git
-# TODO: When will we be able to move to the new rsa?
-
# Use mcdiff to watch for changes
_fn_foobar() {
local _foobar="
@@ -31,12 +29,13 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.3.16',
+requires = ['botocore==1.3.17',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
'rsa>=3.1.2,<=3.3.0']
"
}
+unset -f _fn_foobar
set -u
_pyver="python2"
@@ -48,7 +47,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.9.16
+pkgver=1.9.17
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -57,7 +56,7 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.3.16" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.3.17" # AUR == would make upgrades from AUR impossible. See below.
"${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
#"${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.3.0"} # AUR
"${_pyver}-rsa"{">=3.2","<=3.3.0"} # COM
@@ -79,7 +78,7 @@ depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('772f6d958d919246e09d0d4e5b66a356e9a3f9978e10cba870891564252743b1')
+sha256sums=('5593b19c2edc46d9750e9e8e71d73014f58ead318f7d76ebe0f9f54f7f595a3f')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"