summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-02-10 14:29:39 -0500
committerChris Severance2016-02-10 14:29:39 -0500
commitd47360ace784f83df62b73ef726926a378fbd2fb (patch)
treef375dd9f9464996c4e31a7f471e00b18d5c43662
parent21082307ea70287b176663acf5d02a594077ee8d (diff)
downloadaur-d47360ace784f83df62b73ef726926a378fbd2fb.tar.gz
Update to 1.10.3 and s3transfer
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dd5fc4c7bbc..3e53448f69eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 29 08:39:40 UTC 2016
+# Wed Feb 10 19:26:52 UTC 2016
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.10.1
+ pkgver = 1.10.3
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -11,30 +11,30 @@ pkgbase = python2-aws-cli
makedepends = python2-distribute
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.3.23
+ depends = python2-botocore>=1.3.25
depends = python2-colorama>=0.2.5
- depends = python2-colorama<=0.3.3
depends = python2-rsa>=3.2
depends = python2-rsa<=3.3.0
+ depends = python2-s3transfer>=0.0.1
depends = python2-wheel>=0.24.0
depends = python2-jmespath>=0.7.1
depends = python2-tox>=1.4
depends = python2-dateutil>=2.1
depends = python2-dateutil<3.0.0
depends = python2-nose>=1.3.0
- depends = python2-mock>=1.0.1
+ depends = python2-mock>=1.3.0
depends = python2-docutils>=0.10
depends = python2-six>=1.1.0
- depends = python2-sphinx>=1.1.3
depends = python2-guzzle-sphinx-theme>=0.7.10
depends = python2-guzzle-sphinx-theme<0.8
+ depends = python2-futures
options = !emptydirs
options = !strip
- source = aws-cli-1.10.1.tar.gz::https://github.com/aws/aws-cli/archive/1.10.1.tar.gz
- sha256sums = 0a35dee7d642afa08b359b5c17a0e8f0933d66ce7c7df9657395760365a78264
+ source = aws-cli-1.10.3.tar.gz::https://github.com/aws/aws-cli/archive/1.10.3.tar.gz
+ sha256sums = 976a73d1d28409fd0df52777ffaf840a12ad2e21e6234f978a5efb7213717dce
pkgname = python2-aws-cli
- provides = awscli=1.10.1
+ provides = awscli=1.10.3
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 7eb47b80802b..06fae5dc8898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,20 @@
# Use mcdiff to watch for changes
_fn_foobar() {
local _foobar="
+#requirements-docs.txt
+Sphinx==1.1.3
#requirements.txt
tox==1.4
docutils>=0.10
-Sphinx==1.1.3
# botocore and the awscli packages are typically developed
# in tandem, so we're requiring the latest develop
# branch of botocore when working on the awscli.
-e git://github.com/boto/botocore.git@develop#egg=botocore
+-e git://github.com/boto/s3transfer.git@develop#egg=s3transfer
-e git://github.com/boto/jmespath.git@develop#egg=jmespath
nose==1.3.0
colorama>=0.2.5,<=0.3.3
-mock==1.0.1
+mock==1.3.0
rsa>=3.1.2,<=3.3.0
wheel==0.24.0
@@ -29,10 +31,11 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.3.23',
+requires = ['botocore==1.3.25',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
- 'rsa>=3.1.2,<=3.3.0']
+ 'rsa>=3.1.2,<=3.3.0',
+ 's3transfer==0.0.1']
"
}
unset -f _fn_foobar
@@ -47,7 +50,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.10.1
+pkgver=1.10.3
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -56,29 +59,34 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.3.23" # AUR == would make upgrades from AUR impossible. See below.
- "${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
+ "${_pyver}-botocore>=1.3.25" # AUR == would make upgrades from AUR impossible. See below.
+ #"${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
+ "${_pyver}-colorama>=0.2.5" # COM requested by phw
#"${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.3.0"} # AUR
"${_pyver}-rsa"{">=3.2","<=3.3.0"} # COM
+ "${_pyver}-s3transfer>=0.0.1" # AUR
### These are from python-botocore
"${_pyver}-wheel>=0.24.0" # AUR ==
"${_pyver}-jmespath>=0.7.1" # AUR == is possible for repositories. Makes upgrades impossible in AUR.
- "${_pyver}-tox>=1.4" # COM == is possible because this is from a repository. Unfortunatley Arch isn"t the primary dev environment for botocore/aws so our packages are likely to be newer.
+ "${_pyver}-tox>=1.4" # COM == is possible because this is from a repository. Unfortunatley Arch isnt the primary dev environment for botocore/aws so our packages are likely to be newer.
"${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM
"${_pyver}-nose>=1.3.0" # COM ==
- "${_pyver}-mock>=1.0.1" # COM ==
+ "${_pyver}-mock>=1.3.0" # COM ==
"${_pyver}-docutils>=0.10" # COM
"${_pyver}-six>=1.1.0" # COM This is in the sources but I'm not sure where the version comes from.
# requirements-docs.txt
- "${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work.
+ #"${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work.
"${_pyver}-guzzle-sphinx-theme"{">=0.7.10","<0.8"}
)
+if [ "${_pyver}" = 'python2' ]; then
+ _pydepends+=('python2-futures')
+fi
depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('0a35dee7d642afa08b359b5c17a0e8f0933d66ce7c7df9657395760365a78264')
+sha256sums=('976a73d1d28409fd0df52777ffaf840a12ad2e21e6234f978a5efb7213717dce')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"