summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-24 21:17:52 -0400
committerChris Severance2015-09-24 21:17:52 -0400
commitd526b3bb9894968979738448f0333af8982e067f (patch)
tree8dbc9562130f546b9d60a1b118b6f477405edc30
parent4b1e0643c89bc2c55b7810f3a052db69f9ce0e8d (diff)
downloadaur-d526b3bb9894968979738448f0333af8982e067f.tar.gz
Update to 1.8.7
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0790474813be..7eb37e83ad13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.8.6
+ pkgver = 1.8.7
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -8,17 +8,17 @@ pkgbase = python2-aws-cli
makedepends = python2
makedepends = python2-distribute
options = !emptydirs
- source = aws-cli-1.8.6.tar.gz::https://github.com/aws/aws-cli/archive/1.8.6.tar.gz
- sha256sums = 33b3fced80d179ca9e8d38c2a455070db44495868bc2cb5f4c13b0289e4f7acf
+ source = aws-cli-1.8.7.tar.gz::https://github.com/aws/aws-cli/archive/1.8.7.tar.gz
+ sha256sums = 5edf56f766055e99f0c3f067baf952e231dd1bb8dfc9db4b501a5f8991702c9a
pkgname = python2-aws-cli
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.2.4
+ depends = python2-botocore>=1.2.5
depends = python2-colorama>=0.2.5
depends = python2-colorama<=0.3.3
- depends = python2-rsa-3.1.2>=3.1.2
- depends = python2-rsa-3.1.2<=3.1.4
+ depends = python2-rsa>=3.1.2
+ depends = python2-rsa<=3.3.0
depends = python2-wheel>=0.24.0
depends = python2-jmespath>=0.7.1
depends = python2-tox>=1.4
@@ -31,7 +31,7 @@ pkgname = python2-aws-cli
depends = python2-sphinx>=1.1.3
depends = python2-guzzle-sphinx-theme>=0.7.10
depends = python2-guzzle-sphinx-theme<0.8
- provides = awscli=1.8.6
+ provides = awscli=1.8.7
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index c6cdcdb19100..3835b498c338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,10 +31,10 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.2.4',
+requires = ['botocore==1.2.5',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
- 'rsa>=3.1.2,<=3.1.4']
+ 'rsa>=3.1.2,<=3.3.0']
"
}
@@ -48,7 +48,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.8.6
+pkgver=1.8.7
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -57,10 +57,10 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.2.4" # AUR == would make upgrades from AUR imposible. See below.
- "${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
- "${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.1.4"} # AUR It would be nice to move to the newer version.
- #"${_pyver}-rsa"{">=3.1.2","<=3.1.4"} # COM
+ "${_pyver}-botocore>=1.2.5" # AUR == would make upgrades from AUR imposible. See below.
+ "${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
+ #"${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.3.0"} # AUR
+ "${_pyver}-rsa"{">=3.1.2","<=3.3.0"} # COM
### These are from python-botocore
"${_pyver}-wheel>=0.24.0" # AUR ==
@@ -78,7 +78,7 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('33b3fced80d179ca9e8d38c2a455070db44495868bc2cb5f4c13b0289e4f7acf')
+sha256sums=('5edf56f766055e99f0c3f067baf952e231dd1bb8dfc9db4b501a5f8991702c9a')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"
@@ -100,11 +100,6 @@ else
_vcsconflicts=()
fi
-prepare() {
- msg "Dont run this"
-}
-
-
build() {
set -u
cd "${_srcdir}"