summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-11-01 16:25:21 -0500
committerChris Severance2015-11-01 16:25:21 -0500
commitf4b6b433acb56b16108fe7196e8a4bb32d71e268 (patch)
tree18799523853861d5ef4b11171f04f9a2b0204fc2
parente5dff11f453ae89e5ddfee23e23e0cd5b07bb1e2 (diff)
downloadaur-f4b6b433acb56b16108fe7196e8a4bb32d71e268.tar.gz
Update to 1.9.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7a348109dcf..31e841cacf10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-aws-cli
pkgdesc = Universal Command Line Interface for Amazon Web Services awscli
- pkgver = 1.9.1
+ pkgver = 1.9.2
pkgrel = 1
url = https://github.com/aws/aws-cli
arch = any
@@ -8,13 +8,14 @@ pkgbase = python2-aws-cli
makedepends = python2
makedepends = python2-distribute
options = !emptydirs
- source = aws-cli-1.9.1.tar.gz::https://github.com/aws/aws-cli/archive/1.9.1.tar.gz
- sha256sums = 0409336e28e1416708f9cbce783575e867877bde088ca28bcf9162fbad0cd876
+ options = !strip
+ source = aws-cli-1.9.2.tar.gz::https://github.com/aws/aws-cli/archive/1.9.2.tar.gz
+ sha256sums = 7035649165a758898698eea591c495c7c3a0b868eda3898604b0d8e2dc38d735
pkgname = python2-aws-cli
depends = python2
depends = python2-bcdoc
- depends = python2-botocore>=1.3.1
+ depends = python2-botocore>=1.3.2
depends = python2-colorama>=0.2.5
depends = python2-colorama<=0.3.3
depends = python2-rsa>=3.1.2
@@ -31,7 +32,7 @@ pkgname = python2-aws-cli
depends = python2-sphinx>=1.1.3
depends = python2-guzzle-sphinx-theme>=0.7.10
depends = python2-guzzle-sphinx-theme<0.8
- provides = awscli=1.9.1
+ provides = awscli=1.9.2
conflicts = python-aws-cli
conflicts = python2-aws-cli
conflicts = awscli
diff --git a/PKGBUILD b/PKGBUILD
index 7c39c957c93f..6db8817e8cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ wheel==0.24.0
import awscli
-requires = ['botocore==1.3.1',
+requires = ['botocore==1.3.2',
'colorama>=0.2.5,<=0.3.3',
'docutils>=0.10',
'rsa>=3.1.2,<=3.3.0']
@@ -48,7 +48,7 @@ else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
-pkgver=1.9.1
+pkgver=1.9.2
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
@@ -57,7 +57,7 @@ url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
"${_pyver}-bcdoc" # AUR
- "${_pyver}-botocore>=1.3.1" # AUR == would make upgrades from AUR impossible. See below.
+ "${_pyver}-botocore>=1.3.2" # AUR == would make upgrades from AUR impossible. See below.
"${_pyver}-colorama"{">=0.2.5","<=0.3.3"} # COM
#"${_pyver}-rsa-3.1.2"{">=3.1.2","<=3.3.0"} # AUR
"${_pyver}-rsa"{">=3.1.2","<=3.3.0"} # COM
@@ -76,9 +76,9 @@ _pydepends=( # See setup.py, README.rst, and requirements.txt for version depend
"${_pyver}-guzzle-sphinx-theme"{">=0.7.10","<0.8"}
)
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
-options=('!emptydirs')
+options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('0409336e28e1416708f9cbce783575e867877bde088ca28bcf9162fbad0cd876')
+sha256sums=('7035649165a758898698eea591c495c7c3a0b868eda3898604b0d8e2dc38d735')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
_srcdir="${_pybase}"