summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-16 00:18:16 -0400
committerChris Severance2015-09-16 00:18:16 -0400
commit3fd673bb71a0dfccd035b966c9e22185438f2e9f (patch)
tree1e3906465939e7c0b32270dcb28827e48ba7ef82
parentfdda0852c8bab6e8a37d3156e24ced00d3acf090 (diff)
downloadaur-3fd673bb71a0dfccd035b966c9e22185438f2e9f.tar.gz
Update to 3.5.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c063614275f..015396864259 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python2-aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.5.2
+ pkgver = 3.5.3
pkgrel = 1
url = http://aws.amazon.com/code/6752709412171743
arch = any
license = Apache
makedepends = python2
makedepends = python2-distribute
- source = https://pypi.python.org/packages/source/a/awsebcli/awsebcli-3.5.2.tar.gz
- sha256sums = a753dbff9a9888b50ba13b221e6e8126e4697a1d61ba871e37c4ac782686da5f
+ source = https://pypi.python.org/packages/source/a/awsebcli/awsebcli-3.5.3.tar.gz
+ sha256sums = 3b384526730714268dad4e897193a58819ace42eeed1abd16e4cd7c4a2c2c078
pkgname = python2-aws-eb-cli
depends = python2
@@ -30,5 +30,5 @@ pkgname = python2-aws-eb-cli
depends = python2-dockerpty>=0.3.2
depends = python2-dockerpty<0.4
depends = python2-blessed=1.9.5
- conflicts = python-
+ conflicts = awsebcli
diff --git a/PKGBUILD b/PKGBUILD
index b66be4566b2f..e1c029729ef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,13 +13,13 @@ _pyver="python2"
_pybase='aws-eb-cli'
if [ "${_pyver}" = 'python' ]; then
pkgname="${_pybase}"
-_pyverother='python2'
+_pyverother='python2-'
else
pkgname="${_pyver}-${_pybase}"
-_pyverother='python'
+_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.5.2'
+pkgver='3.5.3'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -29,7 +29,7 @@ makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
_srcdir="${_pybase}-${pkgver}"
#_verwatch=("https://pypi.python.org/simple/${_pybase}/" "${_pybase}-\([0-9\.]\+\)\.tar\.gz" 't')
source=("https://pypi.python.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('a753dbff9a9888b50ba13b221e6e8126e4697a1d61ba871e37c4ac782686da5f')
+sha256sums=('3b384526730714268dad4e897193a58819ace42eeed1abd16e4cd7c4a2c2c078')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -109,7 +109,7 @@ check() {
package() {
set -u
depends=("${_pyver}" "${_pydepends[@]}")
- conflicts=("${_pyverother}-${pkgbase}")
+ conflicts=("${_pyverother}${_pybase}")
cd "${_srcdir}"
${_pyver} 'setup.py' install --root "${pkgdir}"
install -Dpm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"