summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-05-08 23:21:07 -0400
committerChris Severance2019-05-08 23:21:07 -0400
commit4e040927a32dbe681edd520fbfbd0c6a001629b7 (patch)
treea5f716ed95972761823fca4be9e5fd359d6f7787
parente1f26dabbfd43b51a0d5e98ba6c1848457735e05 (diff)
downloadaur-4e040927a32dbe681edd520fbfbd0c6a001629b7.tar.gz
Update to 3.15.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a134adbfa0fc..795ff8eb8dbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Jan 24 04:16:28 UTC 2019
+# Thu May 9 03:21:07 UTC 2019
pkgbase = python2-aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.14.10
+ pkgver = 3.15.0
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python2
makedepends = python2-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.14.10.tar.gz
- sha256sums = cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.15.0.tar.gz
+ sha256sums = 579fc405c36a64ac600f186107152beca986bdb18f201b2d830e2119ead658dd
pkgname = python2-aws-eb-cli
depends = python2
@@ -19,7 +19,9 @@ pkgname = python2-aws-eb-cli
depends = python2-cement=2.8.2
depends = python2-colorama>=0.3.9
depends = python2-colorama<0.4.0
- depends = python2-pathspec=0.5.5
+ depends = python2-future>=0.16.0
+ depends = python2-future<0.17.0
+ depends = python2-pathspec=0.5.9
depends = python2-dateutil>=2.1
depends = python2-dateutil<3.0.0
depends = python2-yaml>=3.10
@@ -33,6 +35,8 @@ pkgname = python2-aws-eb-cli
depends = python2-termcolor=1.1.0
depends = python2-urllib3>=1.24.1
depends = python2-urllib3<1.25
+ depends = python2-wcwidth>=0.1.7
+ depends = python2-wcwidth<0.2.0
depends = python2-docker-compose>=1.23.2
depends = python2-docker-compose<1.24.0
depends = python2-blessed>=1.9.5
diff --git a/PKGBUILD b/PKGBUILD
index 1abc540d30a9..c86394d0c1c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.14.10'
+pkgver='3.15.0'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _srcdir="${_pybasend}-${pkgver}"
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('cc2f32e4dc4c6ddea4033bf9de74cd520f5971249f3a3f5e5c48b7f867a89f6e')
+sha256sums=('579fc405c36a64ac600f186107152beca986bdb18f201b2d830e2119ead658dd')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -47,7 +47,8 @@ requires = [
'botocore>=1.12.29,<1.13',
'cement==2.8.2',
'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
- 'pathspec==0.5.5',
+ 'future>=0.16.0,<0.17.0',
+ 'pathspec==0.5.9',
'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
'requests>=2.20.1,<2.21',
@@ -55,7 +56,8 @@ requires = [
'semantic_version == 2.5.0',
'six>=1.11.0,<1.12.0',
'termcolor == 1.1.0',
- 'urllib3>=1.24.1,<1.25'
+ 'urllib3>=1.24.1,<1.25',
+ 'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
'docker-compose >= 1.23.2, < 1.24.0',
'blessed>=1.9.5',