summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2016-12-24 22:23:51 -0500
committerChris Severance2016-12-24 22:23:51 -0500
commit6be37b5ceeb12d3ebd2eef83a4c345f11b83f99c (patch)
treef91f79fe06954c2e39b4c6db8a39750e5fc6a1de
parent90ec688b71dc01083299611b672270d1d747827e (diff)
downloadaur-6be37b5ceeb12d3ebd2eef83a4c345f11b83f99c.tar.gz
Update to 3.9.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 340ed14e3629..64835e21cd78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Dec 3 06:08:09 UTC 2016
+# Sun Dec 25 03:22:44 UTC 2016
pkgbase = python2-aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.8.5
+ pkgver = 3.9.0
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python2
makedepends = python2-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.8.5.tar.gz
- sha256sums = e58150bb249f0f90490365b5fd9366e091161a7bde18db0f0e669a47d582c21f
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.9.0.tar.gz
+ sha256sums = 6aad6ee6fa20ec72389e6617ddd35dcd264a2fa14d001e6fb5693e648ea530b0
pkgname = python2-aws-eb-cli
depends = python2
@@ -18,14 +18,12 @@ pkgname = python2-aws-eb-cli
depends = python2-botocore>=1.0.1
depends = python2-cement=2.8.2
depends = python2-colorama=0.3.7
- depends = python2-pathspec=0.3.4
+ depends = python2-pathspec=0.5.0
depends = python2-setuptools>=20.0
depends = python2-docopt>=0.6.1
depends = python2-docopt<0.7
depends = python2-requests>=2.6.1
depends = python2-requests<=2.9.1
- depends = python2-texttable>=0.8.1
- depends = python2-texttable<0.9
depends = python2-websocket-client>=0.11.0
depends = python2-websocket-client<1.0
depends = python2-docker-py>=1.1.0
@@ -33,6 +31,7 @@ pkgname = python2-aws-eb-cli
depends = python2-dockerpty>=0.3.2
depends = python2-dockerpty<=0.4.1
depends = python2-semantic_version=2.5.0
+ depends = python2-tabulate=0.7.5
depends = python2-blessed=1.9.5
conflicts = awsebcli
diff --git a/PKGBUILD b/PKGBUILD
index 46cb2836dd1c..e3a6443a74e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybase="${_pybase//-/}"
-pkgver='3.8.5'
+pkgver='3.9.0'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _srcdir="${_pybase}-${pkgver}"
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybase: 0:1}/${_pybase}/${_pybase}-${pkgver}.tar.gz")
-sha256sums=('e58150bb249f0f90490365b5fd9366e091161a7bde18db0f0e669a47d582c21f')
+sha256sums=('6aad6ee6fa20ec72389e6617ddd35dcd264a2fa14d001e6fb5693e648ea530b0')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -47,16 +47,16 @@ requires = ['pyyaml>=3.11',
'botocore>=1.0.1',
'cement==2.8.2',
'colorama==0.3.7',
- 'pathspec==0.3.4',
+ 'pathspec==0.5.0',
'setuptools >= 20.0',
## For docker-compose
'docopt >= 0.6.1, < 0.7',
'requests >= 2.6.1, <= 2.9.1',
- 'texttable >= 0.8.1, < 0.9',
'websocket-client >= 0.11.0, < 1.0',
'docker-py >= 1.1.0, <= 1.7.2',
'dockerpty >= 0.3.2, <= 0.4.1',
- 'semantic_version == 2.5.0'
+ 'semantic_version == 2.5.0',
+ 'tabulate == 0.7.5'
#found further down in setup.py
'blessed==1.9.5',
]