summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-08-18 01:00:03 -0400
committerChris Severance2020-08-18 01:00:03 -0400
commitee9d35a95afdc496ab745cc60443a416fc4f3bd4 (patch)
treeb2fdfe86d04668c9a7b10501d9834516565a5e2f
parente2576db1ee494ec42eddd62afab890beaaa93532 (diff)
downloadaur-ee9d35a95afdc496ab745cc60443a416fc4f3bd4.tar.gz
Update to 3.18.2
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD16
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4a7826c874..7774b9b0eeab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,29 @@
# Generated by mksrcinfo v8
-# Fri Nov 29 23:32:06 UTC 2019
+# Tue Aug 18 05:00:02 UTC 2020
pkgbase = python2-aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.16.0
+ pkgver = 3.18.2
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python2
makedepends = python2-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.16.0.tar.gz
- sha256sums = 03252f15f06f131e17644333cabe0221e446ff36fccad3d9434eeb7aef226c35
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.18.2.tar.gz
+ sha256sums = 70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db
pkgname = python2-aws-eb-cli
depends = python2
- depends = python2-botocore>1.13.0
- depends = python2-botocore<1.14
+ depends = python2-botocore>=1.15
+ depends = python2-botocore<1.16
depends = python2-cement=2.8.2
- depends = python2-colorama>=0.3.9
- depends = python2-colorama<0.4.0
+ depends = python2-colorama>=0.4
+ depends = python2-colorama<1.0
depends = python2-future>=0.16.0
depends = python2-future<0.17.0
depends = python2-pathspec=0.5.9
depends = python2-dateutil>=2.1
- depends = python2-dateutil<3.0.0
- depends = python2-yaml>=3.10
- depends = python2-yaml<=3.13
+ depends = python2-dateutil<2.8.1
depends = python2-requests>=2.20.1
depends = python2-requests<2.21
depends = python2-setuptools>=20.0
@@ -37,9 +35,13 @@ pkgname = python2-aws-eb-cli
depends = python2-urllib3<1.25
depends = python2-wcwidth>=0.1.7
depends = python2-wcwidth<0.2.0
- depends = python2-docker-compose>=1.23.2
- depends = python2-docker-compose<1.24.0
+ depends = python2-yaml>=5.3.1
+ depends = python2-yaml<5.4
+ depends = python2-docker-compose>=1.25.2
+ depends = python2-docker-compose<1.26.0
depends = python2-blessed>=1.9.5
+ depends = python2-docutils<0.16
+ depends = python2-docutils>=0.10
depends = docker>=3.3.0
depends = python2-requests>=2.14.2
conflicts = aws-eb-cli
diff --git a/PKGBUILD b/PKGBUILD
index 2460f1123381..06b9bc1bc342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.16.0'
+pkgver='3.18.2'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _srcdir="${_pybasend}-${pkgver}"
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('03252f15f06f131e17644333cabe0221e446ff36fccad3d9434eeb7aef226c35')
+sha256sums=('70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -44,13 +44,12 @@ _fn_pydepends() {
# Paste in from setup.py. This function does NOT work in zsh.
local _requires="
requires = [
- 'botocore>1.13.0,<1.14',
+ 'botocore>=1.15,<1.16',
'cement==2.8.2',
- 'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
+ 'colorama>=0.4,<1.0', # use the same range that 'docker-compose' uses
'future>=0.16.0,<0.17.0',
'pathspec==0.5.9',
- 'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
- 'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'python-dateutil>=2.1,<2.8.1', # use the same range that 'botocore' uses
'requests>=2.20.1,<2.21',
'setuptools >= 20.0',
'semantic_version == 2.5.0',
@@ -59,8 +58,11 @@ requires = [
'urllib3>=1.24.1,<1.25',
'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
- 'docker-compose >= 1.23.2, < 1.24.0',
+ 'PyYAML>=5.3.1,<5.4', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'docker-compose >= 1.25.2, < 1.26.0',
'blessed>=1.9.5',
+ #Part of Botocore
+ 'docutils<0.16,>=0.10'
]
"
# Convert requires=[] to local _requires=()