summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2021-04-24 13:30:21 +0200
committerJelle van der Waa2021-04-24 13:30:21 +0200
commit470497f26650d0050f2d2369e53a3422e87e638f (patch)
treeae29b7c80da95ba1879699d6b8c3af9ddc5dd700
downloadaur-470497f26650d0050f2d2369e53a3422e87e638f.tar.gz
import from community
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1dd808a0ba5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-backports.shutil_get_terminal_size
+ pkgdesc = The get_terminal_size() function from Python 3.3
+ pkgver = 1.0.0
+ pkgrel = 4
+ url = https://pypi.python.org/pypi/backports.ssl_match_hostname
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2-backports
+ source = https://github.com/chrippa/backports.shutil_get_terminal_size/archive/v1.0.0.tar.gz
+ source = fix-fallback.patch::https://github.com/chrippa/backports.shutil_get_terminal_size/commit/afc5714b.patch
+ md5sums = 82499a36a98dd7ed37c8678e6002a375
+ md5sums = 071e696dba553fd4fcee24b1dfb8ef3a
+
+pkgname = python2-backports.shutil_get_terminal_size
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d29d68b1a146
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=python2-backports.shutil_get_terminal_size
+pkgver=1.0.0
+pkgrel=4
+pkgdesc="The get_terminal_size() function from Python 3.3"
+arch=('any')
+url="https://pypi.python.org/pypi/backports.ssl_match_hostname"
+license=('MIT')
+depends=('python2-backports')
+makedepends=('python2-setuptools')
+source=("https://github.com/chrippa/backports.shutil_get_terminal_size/archive/v$pkgver.tar.gz"
+ fix-fallback.patch::"https://github.com/chrippa/backports.shutil_get_terminal_size/commit/afc5714b.patch")
+md5sums=('82499a36a98dd7ed37c8678e6002a375'
+ '071e696dba553fd4fcee24b1dfb8ef3a')
+
+prepare() {
+ cd backports.shutil_get_terminal_size-$pkgver
+ patch -p1 -i ../fix-fallback.patch # fix fallback size on Linux
+}
+
+package() {
+ cd "$srcdir/backports.shutil_get_terminal_size-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
+ rm "$pkgdir/usr/lib/python2.7/site-packages/backports/__init__.py"*
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}