summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlothar-mar2015-06-11 16:04:36 +0100
committerlothar-mar2015-06-11 16:04:36 +0100
commit26dfef7379db3bccfb733c61f11e574e6f83aa52 (patch)
tree163db9b0ce604f62f4cd68802caaf868d5a86b8e
downloadaur-python2-baker.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8919d47a805e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-baker
+ pkgdesc = Easy, powerful access to Python functions from the command line.
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://bitbucket.org/mchaput/baker/wiki/Home
+ arch = x86_64
+ arch = i686
+ license = Apache License 2.0
+ depends = python2
+ source = http://pypi.python.org/packages/source/B/Baker/Baker-1.3.tar.gz
+ md5sums = e628d935accf915abf6cdef77b81d8d3
+
+pkgname = python2-baker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a82815559552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: lothar_m
+pkgname=python2-baker
+pkgver=1.3
+pkgrel=1
+pkgdesc="Easy, powerful access to Python functions from the command line."
+arch=('x86_64' 'i686')
+url="https://bitbucket.org/mchaput/baker/wiki/Home"
+license=('Apache License 2.0')
+depends=('python2')
+# makedepends=()
+source=("http://pypi.python.org/packages/source/B/Baker/Baker-${pkgver}.tar.gz")
+md5sums=('e628d935accf915abf6cdef77b81d8d3')
+
+build() {
+ cd "$srcdir/Baker-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ # install package
+ cd "$srcdir/Baker-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+