summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-12 13:40:45 +0200
committerMarcell Meszaros2022-06-12 13:43:12 +0200
commit369a8838263827448ae099326f1e72d96adc0fe5 (patch)
treeb41b2223007bd8fc11a3512e3c2a88ddbdc42dc2
parent720a5d01b5a1261e227327b476cc8d17e00d7236 (diff)
downloadaur-python2-beaker.tar.gz
correctly declare BSD license; use PyPI as upstream URL; cosmetic changes
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD34
3 files changed, 32 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ba45eac9118..d4409b97682c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python2-beaker
- pkgdesc = Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications
+ pkgdesc = A Session and Caching library with WSGI Middleware
pkgver = 1.11.0
- pkgrel = 4
- url = https://beaker.readthedocs.io/
+ pkgrel = 5
+ url = https://pypi.org/project/Beaker/
arch = any
- license = custom
+ license = BSD
makedepends = python2-setuptools
depends = python2-funcsigs
- source = python2-beaker-1.11.0.tar.gz::https://github.com/bbangert/beaker/archive/1.11.0.tar.gz
- sha512sums = 0eab9ff40314786e0fb2d31a6b932f355680c193ac5c41de442ee5a3f4d5cf62ae1c30f2948f8e2c89c012bad5e4332a5a72be62c9b1cba0b9f2723afe7e9ae3
+ source = beaker-1.11.0.tar.gz::https://github.com/bbangert/beaker/archive/1.11.0.tar.gz
+ b2sums = ec8d06c13c7cf65199d2b65ef286440608726603a18ea1820e26efdf7f9c96050196aa35b1e320ff8b6bf66ccc1f982338744312743e1ae7c3a1a3c66600ff64
pkgname = python2-beaker
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33f4e24f5b6e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.diff
+!*.hook
+!*.install
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index 6c109912ddb9..bc10ef2608c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: xiretza <xiretza+aur@gmail.com>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Massimiliano Torromeo < massimiliano DOT torromeo AT gmail DOT com >
-pkgname=python2-beaker
+pkgname='python2-beaker'
+_name="${pkgname#python2-}"
pkgver=1.11.0
-pkgrel=4
+pkgrel=5
+pkgdesc='A Session and Caching library with WSGI Middleware'
arch=('any')
-license=('custom')
-pkgdesc="Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications"
-url="https://beaker.readthedocs.io/"
-makedepends=('python2-setuptools')
+url='https://pypi.org/project/Beaker/'
+license=('BSD')
depends=('python2-funcsigs')
-
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bbangert/beaker/archive/$pkgver.tar.gz")
-sha512sums=('0eab9ff40314786e0fb2d31a6b932f355680c193ac5c41de442ee5a3f4d5cf62ae1c30f2948f8e2c89c012bad5e4332a5a72be62c9b1cba0b9f2723afe7e9ae3')
+makedepends=('python2-setuptools')
+_tarname="${_name}-${pkgver}"
+source=("${_tarname}.tar.gz::https://github.com/bbangert/beaker/archive/$pkgver.tar.gz")
+b2sums=('ec8d06c13c7cf65199d2b65ef286440608726603a18ea1820e26efdf7f9c96050196aa35b1e320ff8b6bf66ccc1f982338744312743e1ae7c3a1a3c66600ff64')
prepare() {
# Use a fake MongoDB for tests
sed -e '/class TestMongoDB/i import mongomock' \
-e "s|'mongodb://localhost:27017/beaker_testdb'|mongomock.MongoClient('mongodb://localhost:27017/beaker_testdb')|" \
- -i beaker-$pkgver/tests/test_managers/test_ext_mongodb.py
+ -i "${_tarname}/tests/test_managers/test_ext_mongodb.py"
- sed -i "s#/usr/bin/python#/usr/bin/python2#" "beaker-$pkgver/beaker/crypto/pbkdf2.py"
+ sed -i 's#/usr/bin/python#/usr/bin/python2#' "${_tarname}/beaker/crypto/pbkdf2.py"
}
build() {
- cd "$srcdir/beaker-$pkgver"
+ cd "${_tarname}"
python2 setup.py build
}
package() {
- cd "$srcdir/beaker-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/python2-beaker/LICENSE"
+ cd "${_tarname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}