summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Dvoretsky2015-06-30 20:24:01 +0300
committerEugene Dvoretsky2015-06-30 20:24:01 +0300
commit2fef5e7a1ca5254b9e99390bedce1b04d3a49110 (patch)
tree913cdd588c2ba56470bbde5626973399d76d9ba2
downloadaur-2fef5e7a1ca5254b9e99390bedce1b04d3a49110.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0486cb394d29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-bioformats
+ pkgdesc = Python wrapper for Bio-Formats, a standalone Java library for reading and writing life sciences image file formats.
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/CellProfiler/python-bioformats
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2-javabridge
+ source = https://github.com/CellProfiler/python-bioformats/archive/1.0.5.tar.gz
+ sha256sums = 49ee4d7edef0ef76aa0419559a06ce38b7f7341a9fdefb0accbd92ad2a8861ff
+
+pkgname = python2-bioformats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0b812790413
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eugene Dvoretsky <radioxoma at gmail.com>
+
+pkgname=('python2-bioformats')
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Python wrapper for Bio-Formats, a standalone Java library for reading and writing life sciences image file formats."
+arch=('i686' 'x86_64')
+url="https://github.com/CellProfiler/python-bioformats"
+license=('BSD')
+depends=('python2-javabridge')
+
+source=("https://github.com/CellProfiler/python-bioformats/archive/${pkgver}.tar.gz")
+sha256sums=('49ee4d7edef0ef76aa0419559a06ce38b7f7341a9fdefb0accbd92ad2a8861ff')
+
+build() {
+ cd "$srcdir/python-bioformats-$pkgver"
+ python2 setup.py build
+}
+
+# check() {
+# cd "$srcdir/python-bioformats-$pkgver"
+# python2 setup.py test
+# }
+
+package() {
+ cd "$srcdir/python-bioformats-$pkgver"
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+ install -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}