summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-09 09:59:06 -0400
committerKyle Keen2015-08-09 09:59:06 -0400
commit3f1397c2d9f2bc298f48f97fa425753f9c0f6c68 (patch)
tree5a3e1449d4747affa3c1a6980107053573e21818
downloadaur-3f1397c2d9f2bc298f48f97fa425753f9c0f6c68.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bb9d1d0bb17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-bjoern
+ pkgdesc = A screamingly fast, ultra-lightweight WSGI server for Python, written in C.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/jonashaag/bjoern
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2-setuptools
+ depends = libev
+ depends = python2
+ source = http://pypi.python.org/packages/source/b/bjoern/bjoern-1.4.2.tar.gz
+ md5sums = bd0b1d97a187fd438a8959dfb312683d
+
+pkgname = python2-bjoern
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cd44cdc6dc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+
+pkgname=python2-bjoern
+_pkgname=bjoern
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="A screamingly fast, ultra-lightweight WSGI server for Python, written in C."
+arch=('i686' 'x86_64')
+url="https://github.com/jonashaag/bjoern"
+license=('BSD')
+depends=('libev' 'python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('bd0b1d97a187fd438a8959dfb312683d')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" -O1
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}