summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2016-08-08 16:48:31 +0200
committerCedric Girard2016-08-08 16:48:31 +0200
commitbe2838a272752fc2aa4122a48ae206df8d0a8c9e (patch)
tree7eb50e83364d26a80707b033745a7ad966f085b6
parent7e94cde639073890041c8a17e80c5134e98e27da (diff)
downloadaur-be2838a272752fc2aa4122a48ae206df8d0a8c9e.tar.gz
new upstream version with updated deps
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e332cf734c..7490d2baec15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Apr 28 15:32:10 UTC 2016
pkgbase = python2-boto3
pkgdesc = The AWS SDK for Python
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
url = http://pypi.python.org/pypi/boto3
arch = any
@@ -12,9 +10,10 @@ pkgbase = python2-boto3
depends = python2-botocore>=1.4.1
depends = python2-botocore<1.5.0
depends = python2-jmespath<1.0.0
- depends = python2-futures<4.0.0
- source = https://pypi.io/packages/source/b/boto3/boto3-1.3.1.tar.gz
- md5sums = e6be09a90230390640873979702dd6da
+ depends = python2-s3transfer>=0.1.0
+ depends = python2-s3transfer<0.2.0
+ source = https://pypi.io/packages/source/b/boto3/boto3-1.4.0.tar.gz
+ md5sums = 4b5454e8d29dede99092616023828a21
pkgname = python2-boto3
diff --git a/PKGBUILD b/PKGBUILD
index 06beaf676f25..d358e8027f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
_pythonmod=boto3
pkgname=python2-boto3
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="The AWS SDK for Python"
arch=('any')
url="http://pypi.python.org/pypi/${_pythonmod}"
license=('Apache')
-depends=('python2' 'python2-botocore>=1.4.1' 'python2-botocore<1.5.0' 'python2-jmespath<1.0.0' 'python2-futures<4.0.0')
+depends=(
+ 'python2'
+ 'python2-botocore>=1.4.1'
+ 'python2-botocore<1.5.0'
+ 'python2-jmespath<1.0.0'
+ 'python2-s3transfer>=0.1.0'
+ 'python2-s3transfer<0.2.0'
+ )
makedepends=('python2-setuptools')
source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
-md5sums=('e6be09a90230390640873979702dd6da')
+md5sums=('4b5454e8d29dede99092616023828a21')
build() {
cd ${srcdir}/${_pythonmod}-$pkgver