summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjelle2021-07-20 08:35:44 +0000
committerjelle2021-07-20 08:35:44 +0000
commit506ab70453f222e98d2d3a712d155868d07b3689 (patch)
tree15519dfbb159fa15fd3dfe055af1ec941981fd64
downloadaur-506ab70453f222e98d2d3a712d155868d07b3689.tar.gz
extra2community: Moving python2-cairo from extra to community
git-svn-id: file:///srv/repos/svn-community/svn@979425 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5419a4c118e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-cairo
+ pkgdesc = Python bindings for the cairo graphics library
+ pkgver = 1.18.2
+ pkgrel = 4
+ url = https://pycairo.readthedocs.io/en/latest/
+ arch = x86_64
+ license = LGPL2.1
+ license = MPL
+ makedepends = git
+ depends = cairo
+ depends = python2
+ source = git+https://github.com/pygobject/pycairo/#commit=8643af4c10059827056e769c8c7a997bdc3d5a29
+ sha256sums = SKIP
+
+pkgname = python2-cairo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be4fc17a769d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=python2-cairo
+pkgver=1.18.2
+pkgrel=4
+pkgdesc="Python bindings for the cairo graphics library"
+arch=('x86_64')
+url="https://pycairo.readthedocs.io/en/latest/"
+license=('LGPL2.1' 'MPL')
+depends=(cairo python2)
+makedepends=(git)
+_commit=8643af4c10059827056e769c8c7a997bdc3d5a29 # tags/v1.18.2
+source=("git+https://github.com/pygobject/pycairo/#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pycairo
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd pycairo
+ python2 setup.py build
+}
+
+package() {
+ cd pycairo
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize='1'
+}