summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Correa2018-03-20 15:10:16 -0300
committerVinicius Correa2018-03-20 15:10:16 -0300
commite4620663512e377fa60b7589a3340154535a217b (patch)
treef4c9b5d79df19596aa6a2642cf551cfd9b88cfbe
parentebd307bef13f848794efc7611f8f458f7ca01fe2 (diff)
downloadaur-e4620663512e377fa60b7589a3340154535a217b.tar.gz
updated
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a230d1690be..381b35b63c93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python2-cairosvg
- pkgdesc = A Simple SVG Converter for Cairo
- pkgver = 1.0.9
+ pkgdesc = Convert your SVG files to PDF and PNG.
+ pkgver = 2.1.3
pkgrel = 1
- url = http://cairosvg.org/
+ url = http://cairosvg.org
arch = any
- license = LGPL3
+ license = GPL
+ makedepends = git
depends = python2
- depends = python2-cairo
- optdepends = python2-lxml: To use lxml to parse SVG files
- optdepends = python2-tinycss: Apply CSS not included in the style attribute of the tags
- optdepends = python2-cssselect: Apply CSS not included in the style attribute of the tags
- optdepends = python2-pillow: To handle embedded raster images other than PNG
- source = http://pypi.python.org/packages/source/C/CairoSVG/CairoSVG-1.0.9.tar.gz
- md5sums = 4a15e7cf8debd205f6a9cc4b17c2e411
+ depends = python2-cairocffi
+ depends = python2-cffi
+ depends = python2-pycparser
+ optdepends = python2-lxml
+ source = https://github.com/Kozea/CairoSVG/archive/2.1.3.tar.gz
+ md5sums = 71a576e0e0fa43fbce678e13053e2c02
pkgname = python2-cairosvg
diff --git a/PKGBUILD b/PKGBUILD
index 7f3234c32a53..e4be8c3e0cdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: pzl <alsoelp@gmail.com>
-# Contributor: Dennis Fink <dennis.fink@c3l.lu>
-# Submitter: Simon Sapin <simon dot sapin at exyr dot org>
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=CairoSVG
pkgname=python2-cairosvg
-pkgver=1.0.9
+pkgver=2.1.3
pkgrel=1
-pkgdesc="A Simple SVG Converter for Cairo"
+pkgdesc="Convert your SVG files to PDF and PNG."
arch=('any')
-url="http://cairosvg.org/"
-license=('LGPL3')
-depends=('python2' 'python2-cairo')
-optdepends=('python2-lxml: To use lxml to parse SVG files'
-'python2-tinycss: Apply CSS not included in the style attribute of the tags'
-'python2-cssselect: Apply CSS not included in the style attribute of the tags'
-'python2-pillow: To handle embedded raster images other than PNG')
-source=("http://pypi.python.org/packages/source/C/CairoSVG/CairoSVG-${pkgver}.tar.gz")
-md5sums=('4a15e7cf8debd205f6a9cc4b17c2e411')
+url="http://cairosvg.org"
+license=('GPL')
+depends=('python2' 'python2-cairocffi' 'python2-cffi' 'python2-pycparser')
+makedepends=('git')
+optdepends=('python2-lxml')
+conflicts=()
+source=("https://github.com/Kozea/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('71a576e0e0fa43fbce678e13053e2c02')
build() {
- cd "$srcdir/CairoSVG-$pkgver"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ sed -i 's/import re/import re\nimport io/' setup.py
+ sed -i 's/open/\io.open/' setup.py
python2 setup.py build
}
package() {
- cd "$srcdir/CairoSVG-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
}