summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohamar Rios Flores2016-05-22 19:48:42 -0600
committerMohamar Rios Flores2016-05-22 19:48:42 -0600
commit30954da669f04fbaaf1175988b37701959882568 (patch)
tree749c86e2face523b63a85f044bd45b9604b6d700
downloadaur-30954da669f04fbaaf1175988b37701959882568.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed6bac6c7ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-cashew
+ pkgdesc = The plugin system used by dexy.
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = http://dexy.github.io/cashew/
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-yaml
+ depends = python2-inflection>=0.2.0
+ provides = cashew
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/c/cashew/cashew-0.2.7.tar.gz
+ source = LICENSE::https://raw.githubusercontent.com/dexy/cashew/master/LICENSE
+ md5sums = e7a3801bf2ac92817d33292ea25efe5e
+ md5sums = 7ae0144577340e245b148893690d7f37
+
+pkgname = python2-cashew
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..979fc1214274
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mohamar Rios <mohamar.rios@gmail.com>
+_pkgname=cashew
+pkgname=python2-${_pkgname}
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="The plugin system used by dexy."
+arch=('any')
+url='http://dexy.github.io/cashew/'
+license=('MIT')
+depends=('python2'
+ 'python2-yaml'
+ 'python2-inflection>=0.2.0')
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+provides=("${_pkgname}")
+source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "LICENSE::https://raw.githubusercontent.com/dexy/cashew/master/LICENSE")
+md5sums=('e7a3801bf2ac92817d33292ea25efe5e'
+ '7ae0144577340e245b148893690d7f37')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: