summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2017-06-27 17:08:32 -0400
committerKartik Mohta2017-06-27 17:08:32 -0400
commit162b55ed57a01b558966cac58efc0020171b1ccf (patch)
tree15c6559f0da42ab88f0a632de1c2ec01e9720765
downloadaur-162b55ed57a01b558966cac58efc0020171b1ccf.tar.gz
Fully separate into Python 2 and 3 packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f1fc0eb89d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-catkin_lint
+ pkgdesc = Check catkin packages for common errors
+ pkgver = 1.4.16
+ pkgrel = 2
+ url = https://github.com/fkie/catkin_lint
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-catkin_pkg
+ provides = python2-catkin-lint
+ conflicts = python-catkin_lint
+ conflicts = python2-catkin-lint
+ source = https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-1.4.16.tar.gz
+ md5sums = 6252b8ac505cfc0a87d0064e316db460
+
+pkgname = python2-catkin_lint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a818054d628d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
+
+pkgbase=('python2-catkin_lint')
+pkgname=('python2-catkin_lint')
+_module='catkin_lint'
+pkgver='1.4.16'
+pkgrel=2
+pkgdesc="Check catkin packages for common errors"
+url="https://github.com/fkie/catkin_lint"
+depends=('python2' 'python2-catkin_pkg')
+provides=('python2-catkin-lint')
+conflicts=('python-catkin_lint' 'python2-catkin-lint')
+makedepends=('python2-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-${pkgver}.tar.gz")
+md5sums=('6252b8ac505cfc0a87d0064e316db460')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}