summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaesim2018-02-02 09:17:24 +0200
committerCaesim2018-02-02 09:17:24 +0200
commitc46d35ee7f8a47e485930479a59a7c205ce15bad (patch)
tree211e3b804da298b6bc7013a46194c55301ca5815
parent8102dece4ce860547a7eced2d0a45be512490812 (diff)
downloadaur-c46d35ee7f8a47e485930479a59a7c205ce15bad.tar.gz
1.9.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51426573bcd1..82b36da8f0e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-cfscrape
pkgdesc = A simple Python module to bypass Cloudflare's anti-bot page, using Requests
- pkgver = 1.9.2
+ pkgver = 1.9.3
pkgrel = 1
url = https://github.com/Anorov/cloudflare-scrape
arch = any
@@ -9,10 +9,8 @@ pkgbase = python2-cfscrape
depends = python2-requests
depends = python2-pyexecjs
depends = nodejs
- source = https://files.pythonhosted.org/packages/source/c/cfscrape/cfscrape-1.9.2.tar.gz
- source = https://raw.githubusercontent.com/Anorov/cloudflare-scrape/master/LICENSE
- sha256sums = a10883f9424c7edd27f419209acca9d5af461fbf93e3cb7dfe7188722d3c8d52
- sha256sums = 0dee0611b80471ef37e44bd2e7bcbc59e19251b2f24bf9753cefed002830787a
+ source = https://files.pythonhosted.org/packages/source/c/cfscrape/cfscrape-1.9.3.tar.gz
+ sha256sums = 7ff269d2e88ba8fa97994275b4d58c722c84d39f579624becc89111e72265c64
pkgname = python2-cfscrape
diff --git a/PKGBUILD b/PKGBUILD
index 385d723e498a..529ee86eb290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Caesim404 <caesim404 at gmail dot com>
-
+
pkgname=python2-cfscrape
_pypiname=${pkgname/python2-/}
-pkgver=1.9.2
+pkgver=1.9.3
pkgrel=1
pkgdesc="A simple Python module to bypass Cloudflare's anti-bot page, using Requests"
arch=(any)
@@ -10,16 +10,12 @@ url="https://github.com/Anorov/cloudflare-scrape"
license=(MIT)
depends=(python2-requests python2-pyexecjs nodejs)
makedepends=(python2-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/Anorov/cloudflare-scrape/master/LICENSE")
-sha256sums=('a10883f9424c7edd27f419209acca9d5af461fbf93e3cb7dfe7188722d3c8d52'
- '0dee0611b80471ef37e44bd2e7bcbc59e19251b2f24bf9753cefed002830787a')
+source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+sha256sums=('7ff269d2e88ba8fa97994275b4d58c722c84d39f579624becc89111e72265c64')
+
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${_pypiname}-${pkgver}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- cd "${_pypiname}-${pkgver}"
-
python2 setup.py install --root="$pkgdir" --optimize=1
}