summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2020-01-03 12:27:08 +0100
committerAndrea Scarpino2020-01-03 12:27:08 +0100
commit94bd7b1327ba0744c42fa2b6e8210a8476792fae (patch)
treeb0e20c652475dd74c4489cbf6626688fc2ea5b91
downloadaur-94bd7b1327ba0744c42fa2b6e8210a8476792fae.tar.gz
Restore from Arch Linux packages
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37c9367bb3b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-cheetah
+ pkgdesc = A Python-powered template engine and code generator
+ pkgver = 2.4.4
+ pkgrel = 7
+ url = http://www.cheetahtemplate.org
+ arch = x86_64
+ license = custom
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-markdown
+ optdepends = python2-pygments: for the CodeHighlighter filter
+ provides = cheetah
+ provides = python-cheetah
+ conflicts = cheetah
+ conflicts = python-cheetah
+ source = https://pypi.python.org/packages/source/C/Cheetah/Cheetah-2.4.4.tar.gz
+ sha512sums = 11b8cbf7d71789d6ae83596b133ddbe0bf1ccf2bca4c59562e7cd1d9bb75fa9d3208c0021d7d77edafdb03fd399cf1a26c003267fbffb94f27bf4457b0f9234c
+
+pkgname = python2-cheetah
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebca9ff3c76f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Todd Maynard <arch@toddmaynard.com>
+# Source: https://github.com/nicoulaj/archlinux-packages
+pkgname=python2-cheetah
+pkgver=2.4.4
+pkgrel=7
+pkgdesc="A Python-powered template engine and code generator"
+arch=(x86_64)
+url="http://www.cheetahtemplate.org"
+license=(custom)
+depends=(python2 python2-markdown)
+makedepends=(python2-distribute)
+optdepends=('python2-pygments: for the CodeHighlighter filter')
+provides=(cheetah python-cheetah)
+conflicts=(cheetah python-cheetah)
+source=(https://pypi.python.org/packages/source/C/Cheetah/Cheetah-${pkgver}.tar.gz)
+sha512sums=('11b8cbf7d71789d6ae83596b133ddbe0bf1ccf2bca4c59562e7cd1d9bb75fa9d3208c0021d7d77edafdb03fd399cf1a26c003267fbffb94f27bf4457b0f9234c')
+
+build() {
+ cd "${srcdir}/Cheetah-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ msg "Install..."
+ cd "${srcdir}/Cheetah-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" || return 1
+
+ msg2 "Install copyright resources in /usr/share/licenses/${pkgname}..."
+ install -Dm644 "${srcdir}/Cheetah-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+