summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroneup2017-11-30 23:37:21 -0500
committeroneup2017-11-30 23:37:21 -0500
commit8d361581a91fdff8ab03d27df91aeaf3bff67754 (patch)
treef3cbfd5f48c9b157bef133b5e50da42fa39538d6
downloadaur-8d361581a91fdff8ab03d27df91aeaf3bff67754.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af6e6ba1741c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-cle
+ pkgdesc = CLE Loads Everything (at least, may binary formats!) and provides a Pythonic interface to analyze what they are and what they would look like in memory.
+ pkgver = 7.7.9.21
+ pkgrel = 1
+ url = https://github.com/angr/cle
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-archinfo>=7.7.9.14
+ depends = python2-cffi
+ depends = python2-idalink
+ depends = python2-pefile
+ depends = python2-pyelftools>=0.24
+ depends = python2-pyvex>=7.7.9.14
+ source = https://pypi.python.org/packages/c6/c9/97532224a49d0f919051a65dd99952d50bcb6bc0975a1690c94933d9524a/cle-7.7.9.21.tar.gz
+ source = https://raw.githubusercontent.com/angr/cle/master/LICENSE
+ md5sums = 6efd90cdc587fe428caeb3f52f227b55
+ md5sums = 92da168ebb0065f567f0ea48bed0f512
+
+pkgname = python2-cle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04a213fbbe31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#Automatically generated by pip2arch on 2017-11-21
+
+# Maintainer: oneup <oneup40 at gmail dot com>
+
+pkgname=python2-cle
+pkgver=7.7.9.21
+pkgrel=1
+pkgdesc="CLE Loads Everything (at least, may binary formats!) and provides a Pythonic interface to analyze what they are and what they would look like in memory."
+url="https://github.com/angr/cle"
+depends=('python2' 'python2-archinfo>=7.7.9.14' 'python2-cffi' 'python2-idalink' 'python2-pefile' 'python2-pyelftools>=0.24' 'python2-pyvex>=7.7.9.14')
+makedepends=('python2-distribute' )
+license=('BSD')
+arch=('any')
+source=('https://pypi.python.org/packages/c6/c9/97532224a49d0f919051a65dd99952d50bcb6bc0975a1690c94933d9524a/cle-7.7.9.21.tar.gz'
+ 'https://raw.githubusercontent.com/angr/cle/master/LICENSE')
+md5sums=('6efd90cdc587fe428caeb3f52f227b55'
+ '92da168ebb0065f567f0ea48bed0f512')
+
+build() {
+ cd $srcdir/cle-7.7.9.21
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/cle-7.7.9.21
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 $srcdir/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}