summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrougnouf (Benoit Brummer)2021-11-08 15:19:37 +0100
committertrougnouf (Benoit Brummer)2021-11-08 15:19:37 +0100
commitc1b000307ef517e5f97dc6d4f7f65def002e91aa (patch)
tree7d4cc0148bd424022cceb1c5d31b2f386b9f8c46
downloadaur-c1b000307ef517e5f97dc6d4f7f65def002e91aa.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eae2ae7d1503
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-click
+ pkgdesc = A simple wrapper around optparse for powerful command line utilities
+ pkgver = 7.1.2
+ pkgrel = 1
+ url = http://click.pocoo.org/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://github.com/pallets/click/archive/7.1.2/python2-click-7.1.2.tar.gz
+ sha512sums = d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
+
+pkgname = python2-click
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86e093b8cf02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Trougnouf (Benoit Brummer) <trougnouf@gmail.com>
+# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
+# Contributor: Carl George < arch at cgtx dot us >
+
+pkgname=python2-click
+_realname=click
+pkgver=7.1.2
+pkgrel=1
+pkgdesc="A simple wrapper around optparse for powerful command line utilities"
+arch=("any")
+url="http://click.pocoo.org/"
+license=("BSD")
+depends=("python2")
+makedepends=("python2-setuptools")
+source=("https://github.com/pallets/click/archive/${pkgver}/$pkgname-$pkgver.tar.gz")
+sha512sums=('d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba')
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst"
+}