summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2023-07-11 10:45:08 -0300
committerDanilo J. S. Bellini2023-07-11 10:45:08 -0300
commitea7bbd8678598131998aff28b17b272bdd4cedf2 (patch)
tree3cc0115051137af83f33c62107426a8dd805c5e1
downloadaur-ea7bbd8678598131998aff28b17b272bdd4cedf2.tar.gz
v1.1.1-5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2643caa720f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-click-plugins
+ pkgdesc = Register click CLI commands via setuptools entry-points (Python 2)
+ pkgver = 1.1.1
+ pkgrel = 5
+ url = https://github.com/click-contrib/click-plugins
+ arch = any
+ license = BSD
+ checkdepends = python2-pytest
+ makedepends = python2-setuptools
+ depends = python2-click
+ source = https://github.com/click-contrib/click-plugins/releases/download/1.1.1/click-plugins-1.1.1.tar.gz
+ sha256sums = 46ab999744a9d831159c3411bb0c79346d94a444df9a3a3742e9ed63645f264b
+
+pkgname = python2-click-plugins
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b1e930d2f69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+# Contributor: Matthew McGinn <mamcgi@gmail.com>
+# Contributor: Carl George < arch at cgtx dot us >
+pkgname=python2-click-plugins
+_name=${pkgname#python2-}
+pkgver=1.1.1
+pkgrel=5
+pkgdesc='Register click CLI commands via setuptools entry-points (Python 2)'
+arch=('any')
+url='https://github.com/click-contrib/click-plugins'
+license=('BSD')
+depends=('python2-click')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest')
+source=("$url/releases/download/$pkgver/$_name-$pkgver.tar.gz")
+sha256sums=('46ab999744a9d831159c3411bb0c79346d94a444df9a3a3742e9ed63645f264b')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+
+ # Get rid from the unicode icon, which breaks click's formatter
+ sed -i 's/icon = /&"[Oops]" # /' click_plugins/core.py
+ sed -i /u2020/d tests/test_plugins.py
+}
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 -m pytest -W ignore::DeprecationWarning
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}