summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2015-06-13 00:29:34 -0500
committerXavierCLL2015-06-13 00:29:34 -0500
commitf54c79b3e6542de04ea36e9b135d3c1dc74d7f07 (patch)
tree08169505dcddee07b92edfc1cba39904fc67202c
downloadaur-f54c79b3e6542de04ea36e9b135d3c1dc74d7f07.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2057d273b0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-clusterpy
+ pkgdesc = Clusterpy is a librery of spatially constrained clustering algorithms.
+ pkgver = 0.9.9
+ pkgrel = 1
+ url = http://www.rise-group.org/risem/clusterpy/
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-numpy
+ depends = python2-nose
+ depends = python2-scipy
+ depends = python2-polygon
+ source = https://github.com/clusterpy/clusterpy/releases/download/v0.9.9/clusterPy-0.9.9.tar.gz
+ md5sums = 392beb2c03b14f710055c33547ec7ced
+
+pkgname = python2-clusterpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc895c1f5390
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=python2-clusterpy
+_pkgname=clusterPy
+pkgver=0.9.9
+_pkgver=0.9.9
+pkgrel=1
+pkgdesc="Clusterpy is a librery of spatially constrained clustering algorithms."
+arch=(any)
+url="http://www.rise-group.org/risem/clusterpy/"
+license=('GPL')
+depends=('python2' 'python2-numpy' 'python2-nose' 'python2-scipy' 'python2-polygon')
+makedepends=('python2-distribute')
+#source=($pkgname::git://github.com/clusterpy/clusterpy.git#branch=master)
+source=('https://github.com/clusterpy/clusterpy/releases/download/v0.9.9/clusterPy-0.9.9.tar.gz')
+md5sums=('392beb2c03b14f710055c33547ec7ced')
+
+build() {
+ cd $_pkgname-$_pkgver/
+ python2 setup.py build
+}
+
+package() {
+ cd $_pkgname-$_pkgver/
+ python2 setup.py install --root="$pkgdir"
+}