summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 19:07:19 +0200
committerwillemw122015-06-08 19:07:19 +0200
commit444e92b7359a8862e11c3f55e274e9e36436178b (patch)
tree811a041b7de1778275446c28978527dda7daba23
downloadaur-444e92b7359a8862e11c3f55e274e9e36436178b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a49cc9e3d24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-code-chat-hg
+ pkgdesc = Source code to HTML translator (literate programming)
+ pkgver = r526.8536898ac3f4
+ pkgrel = 1
+ url = https://bitbucket.org/bjones/documentation/overview
+ arch = any
+ license = GPL3
+ makedepends = mercurial
+ makedepends = python2-setuptools
+ depends = python2-docutils
+ provides = python2-code-chat
+ conflicts = python2-code-chat
+ source = python2-code-chat-hg::hg+https://bitbucket.org/bjones/documentation
+ md5sums = SKIP
+
+pkgname = python2-code-chat-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f06631025e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=python2-code-chat
+pkgname=$_pkgname-hg
+pkgver=r526.8536898ac3f4
+pkgrel=1
+pkgdesc="Source code to HTML translator (literate programming)"
+arch=('any')
+url="https://bitbucket.org/bjones/documentation/overview"
+license=('GPL3')
+depends=('python2-docutils')
+makedepends=('mercurial' 'python2-setuptools')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::hg+https://bitbucket.org/bjones/documentation)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd $pkgname
+ sed -i 's/env python/env python2/' setup.py
+}
+
+package() {
+ cd $pkgname
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+