summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:34:24 +0200
committerAndrzej Giniewicz2015-07-07 21:34:24 +0200
commit5af4406db3f0d874481c5378ca73f004a0e43a63 (patch)
treeb5eb983ec58c076ae96673fb1756889475735f92
downloadaur-python2-codetools.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..698ce77c1366
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-codetools
+ pkgdesc = Code Analysis and Execution Tools
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = https://github.com/enthought/codetools
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2-traits
+ conflicts = python2-codetools-git
+ conflicts = python-ets-codetools-svn
+ options = !emptydirs
+ source = https://github.com/enthought/codetools/archive/4.2.0.tar.gz
+ md5sums = bb1554c7deeb2d1821ad097344efd3eb
+
+pkgname = python2-codetools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..502acf86c085
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-codetools
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Code Analysis and Execution Tools"
+arch=('any')
+url="https://github.com/enthought/codetools"
+license=('BSD')
+depends=('python2-traits')
+makedepends=('python2-distribute')
+conflicts=('python2-codetools-git' 'python-ets-codetools-svn')
+options=(!emptydirs)
+
+source=("https://github.com/enthought/codetools/archive/${pkgver}.tar.gz")
+md5sums=('bb1554c7deeb2d1821ad097344efd3eb')
+
+build() {
+ cd "$srcdir"/codetools-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/codetools-$pkgver
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find "${pkgdir}" -name '*.py')
+
+ install -D "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+