summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-07-07 20:52:59 -0700
committermutantmonkey2013-07-07 20:52:59 -0700
commit6b94c08381842f6bf063c17095829387b27d8042 (patch)
tree723e21681d30baa81881c198097da1c62f66df5c
downloadaur-6b94c08381842f6bf063c17095829387b27d8042.tar.gz
add python2-colorpy
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8eaecb9b1330
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-colorpy
+ pkgdesc = Python package that can convert physical descriptions of light into RGB colors
+ pkgver = 0.1.0
+ pkgrel = 2
+ url = http://markkness.net/colorpy/ColorPy.html
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-numpy
+ options = !emptydirs
+ source = http://markkness.net/colorpy/dist/colorpy-0.1.0.tar.gz
+ sha256sums = 6ffe5311a61d17aac76eec216fa66e959a41cdc4a627d418ee1bf0ada9a777fd
+
+pkgname = python2-colorpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcbad0595f4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=python2-colorpy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Python package that can convert physical descriptions of light into RGB colors"
+arch=('any')
+url="http://markkness.net/colorpy/ColorPy.html"
+license=('GPL')
+depends=('python2')
+options=(!emptydirs)
+source=("http://markkness.net/colorpy/dist/colorpy-${pkgver}.tar.gz")
+sha256sums=('6ffe5311a61d17aac76eec216fa66e959a41cdc4a627d418ee1bf0ada9a777fd')
+
+package() {
+ cd "$srcdir/colorpy-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: