summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorApplebloom2016-04-05 06:06:32 +0200
committerApplebloom2016-04-05 06:06:32 +0200
commit858f1606af81a124721ecf120d937837309eb6c9 (patch)
tree6484ea45bdb8f6677400aef9d70e743f3d881759
downloadaur-858f1606af81a124721ecf120d937837309eb6c9.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2ded680519b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 04:03:57 UTC 2016
+pkgbase = python2-commentjson-git
+ pkgdesc = Add JavaScript or Python style comments in JSON.
+ pkgver = r25.1b61eb5
+ pkgrel = 1
+ url = https://github.com/ethifus/commentjson
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ provides = python2-commentjson
+ conflicts = python2-commentjson
+ source = git+https://github.com/ethifus/commentjson.git
+ sha256sums = SKIP
+
+pkgname = python2-commentjson-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0335078b0f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+
+_pkgname="python2-commentjson"
+pkgname="$_pkgname-git"
+pkgver=r25.1b61eb5
+pkgrel=1
+pkgdesc="Add JavaScript or Python style comments in JSON."
+arch=('any')
+license=('MIT')
+url='https://github.com/ethifus/commentjson'
+depends=('python2')
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("git+https://github.com/ethifus/commentjson.git")
+sha256sums=('SKIP')
+
+_srcdir="commentjson"
+
+pkgver() {
+ cd $_srcdir
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_srcdir
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}