summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-06-14 12:12:32 +0800
committerDario Giovannetti2015-06-14 12:12:32 +0800
commitf677792827d3617a7203e4cab24fc638d49b3060 (patch)
treea6e7008ca2f16cc1e1e4c389ab6f111a727c9419
downloadaur-f677792827d3617a7203e4cab24fc638d49b3060.tar.gz
Init commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..274f7efdf6ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-configfile
+ pkgdesc = Python2 library for dynamically parsing and editing configuration files with support for subsections.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://kynikos.github.io/lib.py.configfile
+ arch = any
+ license = GPL3
+ depends = python2
+ source = http://downloads.sourceforge.net/project/kynikos/lib.py.configfile/python2-configfile-1.1.1.tar.bz2
+ sha256sums = 45492f357f242d4acfe9d1ce079f8e3e131b4269fe88f99e7e56d47959ae80df
+
+pkgname = python2-configfile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9897d6268ef9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/python2-configfile
+/*.pkg.tar.xz
+/*.src.tar.gz
+/*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd5558794012
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='python2-configfile'
+pkgver='1.1.1'
+pkgrel=1
+pkgdesc="Python2 library for dynamically parsing and editing configuration files with support for subsections."
+arch=('any')
+url="https://kynikos.github.io/lib.py.configfile"
+license=('GPL3')
+depends=('python2')
+source=("http://downloads.sourceforge.net/project/kynikos/lib.py.configfile/$pkgname-$pkgver.tar.bz2")
+sha256sums=('45492f357f242d4acfe9d1ce079f8e3e131b4269fe88f99e7e56d47959ae80df')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}