summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2020-03-17 12:56:28 +1300
committerMorgenstern2020-03-17 12:56:28 +1300
commit60ca94331c57a8bfffd0232b5c5fb8ae1438055a (patch)
tree679a47a32ca1344f9f0cf970d10d2862fc4ff570
downloadaur-60ca94331c57a8bfffd0232b5c5fb8ae1438055a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88bb5fc3e1b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-configobj
+ pkgdesc = Simple but powerful Python config file reader and writer, python2 version
+ pkgver = 5.0.6
+ pkgrel = 6
+ url = https://github.com/DiffSK/configobj
+ arch = any
+ license = BSD
+ makedepends = python2
+ depends = python2-six
+ source = python2-configobj-5.0.6.tar.gz::https://github.com/DiffSK/configobj/archive/v5.0.6.tar.gz
+ sha256sums = 2e140354efcca6f558ff9ee941b435ae09a617bc071797bef62c8d6ed2033d5e
+
+pkgname = python2-configobj
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419d82fff36c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Manuel "ekerazha" C. (www.ekerazha.com)
+
+_pyname=configobj
+pkgname=('python2-configobj')
+pkgver=5.0.6
+pkgrel=6
+pkgdesc='Simple but powerful Python config file reader and writer, python2 version'
+arch=('any')
+url="https://github.com/DiffSK/configobj"
+license=('BSD')
+depends=('python2-six')
+makedepends=('python2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/DiffSK/configobj/archive/v$pkgver.tar.gz")
+sha256sums=('2e140354efcca6f558ff9ee941b435ae09a617bc071797bef62c8d6ed2033d5e')
+
+package() {
+ cd "$_pyname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: