summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-02-06 18:05:39 -0500
committerCarlos Aznarán Laos2022-02-06 18:05:39 -0500
commitca8d82e19da72568791a9a56d2069ca33ad6cee2 (patch)
tree2308bcdbbe2f40232460a8ac19b1b9653c69459d
parenta2b287be239ad02d8a64620750dcca22e6e489bd (diff)
downloadaur-ca8d82e19da72568791a9a56d2069ca33ad6cee2.tar.gz
Version bump to 4.34.251
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD38
3 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7951cd01c42e..07663cca5f03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python2-copasi-bin
pkgdesc = Python bindings for the COmplex PAthway SImulator (COPASI)
- pkgver = 4.8
+ pkgver = 4.34.251
pkgrel = 1
- url = http://www.copasi.org/
+ url = http://copasi.org
arch = i686
arch = x86_64
- license = Artistic 2.0
+ license = custom:Artistic 2.0
depends = python2>=2.7
+ source = https://pypi.org/packages/cp27/p/python-copasi/python_copasi-4.34.251-cp27-cp27m-manylinux_2_5_x86_64.manylinux1_x86_64.whl
+ sha256sums = 0d6b2b622566d77aac72d951542530c1fcadba6efefe7815fee38d049b7e1481
pkgname = python2-copasi-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9d314f39cfa0..f345d537a8ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,27 @@
-# Maintainer: Michael Schubert <mschu.dev at gmail>
-
-pkgname=python2-copasi-bin
-pkgver=4.8
-_pkgver=35
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+_base=copasi
+pkgname=python2-${_base}-bin
+pkgver=4.34.251
pkgrel=1
pkgdesc="Python bindings for the COmplex PAthway SImulator (COPASI)"
arch=('i686' 'x86_64')
-url="http://www.copasi.org/"
-license=('Artistic 2.0')
+url="http://${_base}.org"
+license=('custom:Artistic 2.0')
depends=('python2>=2.7')
-
+_wheel="python_${_base}-${pkgver}-cp27-cp27m-manylinux_2_5_${CARCH}"
+source=(https://pypi.org/packages/cp27/p/python-${_base}/${_wheel}.manylinux1_${CARCH}.whl)
if [ $CARCH == 'i686' ]; then
- _pkgname=copasi${_pkgver}_python27_linux_x86 && \
- source=("http://www.comp-sys-bio.org/mirror.copasi.org/$_pkgname.tar.bz2") && \
- md5sums=('292c9fca6f7d9e0c68cc0c96155f32ea')
+ sha256sums=('c7bb56b093088fc967318ab3a31a4b0016cd93276f9616657ddbdcd7199d79b4')
elif [ $CARCH == 'x86_64' ]; then
- _pkgname=copasi${_pkgver}_python27_linux_x64 && \
- source=("http://www.comp-sys-bio.org/mirror.copasi.org/$_pkgname.tar.bz2") && \
- md5sums=('67cd2c3d46f52aacd4272d7b915a56fc')
+ sha256sums=('0d6b2b622566d77aac72d951542530c1fcadba6efefe7815fee38d049b7e1481')
fi
package() {
- cd "$srcdir/$_pkgname"
- pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
- install -Dm755 COPASI.py "$pkgdir/$pydir/COPASI.py"
- install -Dm644 _COPASI.so "$pkgdir/$pydir/_COPASI.so"
-
- cd "$pkgdir/$pydir"
- python2 -c "import py_compile; py_compile.compile('COPASI.py')"
+ cd ${_base^^}
+ pydir=$(python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
+ install -Dm644 __init__.py "${pkgdir}/${pydir}/${_base^^}/__init__.py"
+ install -Dm644 _COPASI.so "${pkgdir}/${pydir}/${_base^^}/_${_base^^}.so"
+ # cd "$pkgdir/$pydir"
+ # python2 -c "import py_compile; py_compile.compile('COPASI.py')"
}