summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLingMan2023-04-28 16:21:51 +0200
committerLingMan2023-04-28 16:21:51 +0200
commit158c82992a49721abb436bbd8440f432d49edb79 (patch)
treef447815da985bfe4c9f38a0551e7d33438202472
parentee994362ff9bb8eab17bf998389d18e3baa66cff (diff)
downloadaur-158c82992a49721abb436bbd8440f432d49edb79.tar.gz
Explicitly build against OpenSSL 1.1
Otherwise we end up building against the OpenSSL 3 headers even though this version of cryptography doesn't support OpenSSL 3. Fixes errors such as: ImportError: /usr/lib/python2.7/site-packages/cryptography/hazmat/bindings/_openssl.so: undefined symbol: ERR_new
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25188b19a5bb..9b15d6929543 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,11 @@ sha512sums=('55f6ee13342b3209b1fcb310f4c4d33d22856ee785cb2347e6ad36c34e9b42f6e0d
build() {
cd cryptography-$pkgver
+
+ # Explicitly build against OpenSSL 1.1. Otherwise we end up building against the OpenSSL 3 headers
+ # even though this version of cryptography doesn't support OpenSSL 3, yet.
+ CFLAGS+=" -I/usr/include/openssl-1.1"
+ LDFLAGS+=" -L/usr/lib/openssl-1.1"
python2 setup.py build
}