summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-07-12 17:34:03 +0200
committerSébastien Leduc2015-07-12 17:34:03 +0200
commit26dbe3931cdd5a5bcdaf396874c600c49970092a (patch)
tree41fc7b79c0f723c73a25508deb967a10d0bea06b
downloadaur-python2-ctypes.tar.gz
initial commit for python2-ctypes
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34a4137cd6d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-ctypes
+ pkgdesc = Create and manipulate C data types in Python, call functions in shared libraries
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/ctypes
+ arch = any
+ license = MIT
+ depends = python2
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/project/ctypes/ctypes/1.0.2/ctypes-1.0.2.tar.gz
+ md5sums = 94ff7aa7f7f71b23bac8a98065d77743
+
+pkgname = python2-ctypes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0868e1bd74c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: S.leduc <sebastien@sleduc.fr>
+# Contributor: Shanto <shanto@hotmail.com>
+
+pkgname=python2-ctypes
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Create and manipulate C data types in Python, call functions in shared libraries"
+arch=(any)
+url="http://pypi.python.org/pypi/ctypes"
+license=('MIT')
+depends=('python2')
+options=(!emptydirs)
+source=("http://downloads.sourceforge.net/project/ctypes/ctypes/$pkgver/ctypes-$pkgver.tar.gz")
+md5sums=('94ff7aa7f7f71b23bac8a98065d77743')
+
+package() {
+ cd "$srcdir/${pkgname/python2-/}-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: