summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitriy Morozov2015-06-23 09:31:33 -0700
committerDmitriy Morozov2015-06-23 09:31:33 -0700
commit1308ae96fcdd5df2cd8488104cde19f0d9aba233 (patch)
tree53bcd99773f140bdea7a120dc62e1bbdc8e4e4f8
downloadaur-1308ae96fcdd5df2cd8488104cde19f0d9aba233.tar.gz
Initial commit for AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c1fcc7bea16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-cvxmod
+ pkgdesc = Convex optimization modelling in Python
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = http://cvxmod.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = python2-cvxopt
+ source = http://cvxmod.net/dist/python2-cvxmod-0.4.6.tar.gz
+ md5sums = e5d859659853809e5c7fc2e2970be88e
+
+pkgname = python2-cvxmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23469d9cc427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Contributor: Dmitriy Morozov <archlinux@foxcub.org>
+pkgname=python2-cvxmod
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="Convex optimization modelling in Python"
+url="http://cvxmod.net"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('python2' 'python2-cvxopt')
+source=(http://cvxmod.net/dist/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ python2 setup.py install --root=$startdir/pkg
+}
+md5sums=('e5d859659853809e5c7fc2e2970be88e')