summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 08:53:08 -0700
committerJonathan Yantis2015-06-11 08:53:08 -0700
commit32be82b5b98b7a896b03f8184120db06b98e8906 (patch)
tree5e50c36e1bdbe97cfaf7d89a784f2803c3696928
downloadaur-python2-cytoolz-git.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD56
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9251071faa5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-cytoolz-git
+ pkgdesc = Cython implementation of Toolz for Python 2. High performance functional utilities.
+ pkgver = 0.7.4dev.r172.c9f6b06
+ pkgrel = 2
+ url = http://github.com/pytoolz/cytoolz
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python2-setuptools
+ makedepends = cython2
+ makedepends = python2-nose
+ depends = python2
+ provides = python2-cytoolz
+ conflicts = python2-cytoolz
+ source = git+http://github.com/pytoolz/cytoolz.git
+ sha256sums = SKIP
+
+pkgname = python2-cytoolz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b98293521ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python2-cytoolz-git
+pkgver=0.7.4dev.r172.c9f6b06
+pkgrel=2
+pkgdesc='Cython implementation of Toolz for Python 2. High performance functional utilities.'
+arch=('any')
+url='http://github.com/pytoolz/cytoolz'
+license=('BSD')
+depends=('python2')
+source=('git+http://github.com/pytoolz/cytoolz.git')
+sha256sums=('SKIP')
+makedepends=('git' 'python2-setuptools' 'cython2' 'python2-nose')
+provides=('python2-cytoolz')
+conflicts=('python2-cytoolz')
+
+pkgver() {
+ cd cytoolz
+ set -o pipefail
+ _gitversion=$( git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+
+ if [ -f "cytoolz/_version.py" ]; then
+ printf "%s.%s" "$(grep -R "__version__ =" cytoolz/_version.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ else
+ printf "%s" $_gitversion
+ fi
+}
+build() {
+ cd cytoolz
+
+ # Patch any #!/usr/bin/python to #!/usr/bin/python2
+ for file in $(find . -name '*.py' -print); do
+ sed -r -i 's_^#!.*/usr/bin/python(\s|$)_#!/usr/bin/python2_' $file
+ sed -r -i 's_^#!.*/usr/bin/env(\s)*python(\s|$)_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py build
+}
+
+package() {
+ cd cytoolz
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim:set ts=2 sw=2 et: