summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:02:00 +0200
committeranthraxx2015-06-18 18:02:00 +0200
commit9183668e9b903ca4ee9e00095e91f701b8821641 (patch)
tree39221ce3aeed33d0c9c68c793523aa5e1a775900
downloadaur-python2-darts.util.lru.tar.gz
addpkg: python2-darts.util.lru 0.5-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d67623a2d23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-darts.util.lru
+ pkgdesc = Library that provides a simple dictionary with LRU behaviour
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/darts.util.lru
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-darts.util.lru-0.5.tar.gz::https://pypi.python.org/packages/source/d/darts.util.lru/darts.util.lru-0.5.tar.gz
+ sha512sums = 900734e1c93dd91aa844179ed5eb144d2c43e8ce7760d08e5216d87b700e6bdb0062f7585237449708cd95284a353870c9051637199ee95ebe9b54e67ff866e9
+
+pkgname = python2-darts.util.lru
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1e4101764e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+
+pkgname=python2-darts.util.lru
+_pyname=darts.util.lru
+pkgver=0.5
+pkgrel=1
+pkgdesc="Library that provides a simple dictionary with LRU behaviour"
+url="https://pypi.python.org/pypi/darts.util.lru"
+arch=('any')
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=(${pkgname}-${pkgver}.tar.gz::https://pypi.python.org/packages/source/d/${_pyname}/${_pyname}-${pkgver}.tar.gz)
+sha512sums=('900734e1c93dd91aa844179ed5eb144d2c43e8ce7760d08e5216d87b700e6bdb0062f7585237449708cd95284a353870c9051637199ee95ebe9b54e67ff866e9')
+
+package() {
+ cd ${_pyname}-${pkgver}
+ python2 setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ install -Dm 644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
+
+# vim: ts=2 sw=2 et: