summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarryhaja2016-11-23 22:00:33 -0800
committerlarryhaja2016-11-23 22:00:33 -0800
commit218effc57f148429ccce86994af208da6233b47b (patch)
tree5587142b2731033c688b0da5178876fff3e0027c
parent99a7bdd0ce446527273a86bf97c024ac1c3de9a0 (diff)
downloadaur-218effc57f148429ccce86994af208da6233b47b.tar.gz
updating to version 0.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae8a4abde63f..42e0a752ff09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
-# Generated by makepkg 4.2.1
-# Thu Jun 11 21:35:42 UTC 2015
+# Generated by makepkg 5.0.1
+# Thu Nov 24 05:50:28 UTC 2016
pkgbase = python2-dex
pkgdesc = A MongoDB performance tuning tool that compares queries to the available indexes in the queried collection(s) and generates index suggestions based on simple heuristics.
- pkgver = 0.5.5
+ pkgver = 0.6
pkgrel = 1
- url = http://blog.mongolab.com/2012/06/introducing-dex-the-index-bot/
+ url = https://github.com/mongolab/dex
arch = i686
arch = x86_64
license = MIT
@@ -12,8 +12,8 @@ pkgbase = python2-dex
depends = python2-pymongo
depends = python2-yaml
depends = python2-dargparse
- source = http://pypi.python.org/packages/source/D/Dex/Dex-0.5.5.tar.gz
- md5sums = 0071c3b03d154d2a562e5fe9f9b0a026
+ source = https://pypi.python.org/packages/cd/f4/46dd14cd7787b66f69b02cb5771247eaf6078913a5dccbff0f0ce0825bdb/Dex-0.6.tar.gz
+ sha256sums = e806ac09cca481a0bc67f71c43ce313e3e7276ca8c444eb49af4fa620f96ee70
pkgname = python2-dex
diff --git a/PKGBUILD b/PKGBUILD
index 933093265fd4..9fed6dea9400 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Larry Hajali <larryhaja[at]gmail[dot]com>
pkgname=python2-dex
-pkgver=0.5.5
+_pkgname=Dex
+pkgver=0.6
pkgrel=1
pkgdesc="A MongoDB performance tuning tool that compares queries to the available indexes in the queried collection(s) and generates index suggestions based on simple heuristics."
arch=('i686' 'x86_64')
-url="http://blog.mongolab.com/2012/06/introducing-dex-the-index-bot/"
+url="https://github.com/mongolab/dex"
license=('MIT')
depends=('python2>=2.7' 'python2-pymongo' 'python2-yaml' 'python2-dargparse')
-source=("http://pypi.python.org/packages/source/D/Dex/Dex-${pkgver}.tar.gz")
-md5sums=('0071c3b03d154d2a562e5fe9f9b0a026')
+source=("https://pypi.python.org/packages/cd/f4/46dd14cd7787b66f69b02cb5771247eaf6078913a5dccbff0f0ce0825bdb/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('e806ac09cca481a0bc67f71c43ce313e3e7276ca8c444eb49af4fa620f96ee70')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build
+}
package() {
- cd "${srcdir}/Dex-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="$pkgdir" --optimize=1
}