summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2015-07-23 20:20:58 +0800
committerFelix Yan2015-07-23 20:20:58 +0800
commiteabdeac85bcd0c6e817273b80358134f783a5102 (patch)
treed339bb5f16aae7fe3d7961c48fe4510582d05768
downloadaur-eabdeac85bcd0c6e817273b80358134f783a5102.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
3 files changed, 44 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..cce0f949bd78
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = python2-dict2xml
+ pkgdesc = Super Simple utility to convert a python dictionary into an xml string
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/delfick/python-dict2xml
+ arch = any
+ license = GPL2
+ depends = python2
+ source = https://pypi.python.org/packages/source/d/dict2xml/dict2xml-1.3.tar.gz
+
+pkgname = python2-dict2xml
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b16f12693299
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-dict2xml
+ pkgdesc = Super Simple utility to convert a python dictionary into an xml string
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/delfick/python-dict2xml
+ arch = any
+ license = GPL2
+ depends = python2
+ source = https://pypi.python.org/packages/source/d/dict2xml/dict2xml-1.3.tar.gz
+ sha512sums = 25cd5c8e0210b28e7428b36dac59b11c481c35b6e9946a6f9e4341ae49d013f6e0f119501b8ac6d427e07ea964ff2bfc862d1c0a8c69f0303665d4f84634f24a
+
+pkgname = python2-dict2xml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d8fae4a7af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=python2-dict2xml
+_pypiname=dict2xml
+pkgver=1.3
+pkgrel=1
+pkgdesc="Super Simple utility to convert a python dictionary into an xml string"
+arch=('any')
+url="https://github.com/delfick/python-dict2xml"
+license=('GPL2')
+depends=('python2')
+source=("https://pypi.python.org/packages/source/d/dict2xml/${_pypiname}-${pkgver}.tar.gz")
+sha512sums=('25cd5c8e0210b28e7428b36dac59b11c481c35b6e9946a6f9e4341ae49d013f6e0f119501b8ac6d427e07ea964ff2bfc862d1c0a8c69f0303665d4f84634f24a')
+
+package() {
+ cd "${srcdir}/${_pypiname}-${pkgver}"
+ python2 setup.py install --root "${pkgdir}"
+}
+