summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2015-06-09 11:12:13 +0200
committerMassimiliano Torromeo2015-06-09 11:12:13 +0200
commitdb01428c16012e75fb1f5dc09b4d060f6daa8dbc (patch)
tree15534867ccbeabe458fd38637338d9e00c5f51cd
downloadaur-db01428c16012e75fb1f5dc09b4d060f6daa8dbc.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE.md60
-rw-r--r--PKGBUILD28
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3eba71272e99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-dictshield
+ pkgdesc = Python Library for typed dictionaries... sorta
+ pkgver = 0.4.4
+ pkgrel = 2
+ url = http://github.com/j2labs/dictshield
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ source = http://pypi.python.org/packages/source/d/dictshield/dictshield-0.4.4.tar.gz
+ source = LICENSE.md
+ sha256sums = 1ca7e2b777d6a43d6fd8d8ac2acfb9f350cba71d104f49689da4e09ebf682248
+ sha256sums = 3b6a6793876fd90603d0b444d0fd0def7bc4ece10b1ad752448001757b9483e4
+
+pkgname = python2-dictshield
+
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..4655d100fd68
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,60 @@
+# Copyright 2012 J2 Labs LLC. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ 3. Neither the name of DictShield nor the names of its contributors may be
+ used to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY J2 Labs LLC ``AS IS'' AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+EVENT SHALL J2 Labs LLC OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+The views and conclusions contained in the software and documentation are
+those of the authors and should not be interpreted as representing official
+policies, either expressed or implied, of J2 Labs LLC.
+
+
+# Copyright (c) Django Software Foundation and individual contributors.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ 3. Neither the name of Django nor the names of its contributors may be used
+ to endorse or promote products derived from this software without
+ specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcd222a4e9af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python2-dictshield
+_libname=dictshield
+pkgver=0.4.4
+pkgrel=2
+pkgdesc="Python Library for typed dictionaries... sorta"
+arch=(any)
+url="http://github.com/j2labs/dictshield"
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz"
+ LICENSE.md)
+
+build() {
+ cd "$srcdir/$_libname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_libname-$pkgver"
+ python2 setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm0644 "$srcdir/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}
+
+sha256sums=('1ca7e2b777d6a43d6fd8d8ac2acfb9f350cba71d104f49689da4e09ebf682248'
+ '3b6a6793876fd90603d0b444d0fd0def7bc4ece10b1ad752448001757b9483e4')