summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-02-15 23:17:32 +0100
committerkpcyrd2018-02-15 23:17:32 +0100
commit4026cddb719dbd99a6f3f9002e91dc89f8c8a58d (patch)
tree69288939e9758e6d0e35aaea1a48a8750032497c
downloadaur-4026cddb719dbd99a6f3f9002e91dc89f8c8a58d.tar.gz
v1.7.4-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3b139238b65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-dicttoxml
+ pkgdesc = Converts a Python dictionary or other native data type into a valid XML string.
+ pkgver = 1.7.4
+ pkgrel = 1
+ url = https://github.com/quandyfactory/dicttoxml
+ arch = any
+ license = GPL
+ depends = python
+ source = https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9/dicttoxml-1.7.4.tar.gz
+ sha256sums = ea44cc4ec6c0f85098c57a431a1ee891b3549347b07b7414c8a24611ecf37e45
+
+pkgname = python2-dicttoxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..416aee10edbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+# Contributor: Jose Riha <jose1711 gmail com>
+
+pkgname=python2-dicttoxml
+pkgver=1.7.4
+pkgrel=1
+pkgdesc="Converts a Python dictionary or other native data type into a valid XML string."
+url="https://github.com/quandyfactory/dicttoxml"
+depends=('python')
+license=('GPL')
+arch=('any')
+source=("https://pypi.python.org/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9/dicttoxml-${pkgver}.tar.gz")
+sha256sums=('ea44cc4ec6c0f85098c57a431a1ee891b3549347b07b7414c8a24611ecf37e45')
+
+build() {
+ cd dicttoxml-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd dicttoxml-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
+}
+
+# vim: ts=2 sw=2 et: