summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-12-31 01:36:09 +0100
committerJ5lx2015-12-31 01:36:09 +0100
commitb5910cdbdb3e8e1a76627cf02241b0796d117553 (patch)
tree0976772172256e0287956b838202394218cec2a2
parentb08a56b5a18e6087e3c7a2bcd22343d9ca8d34d0 (diff)
downloadaur-b5910cdbdb3e8e1a76627cf02241b0796d117553.tar.gz
0.11-2: Make the package work with webassets 0.11.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ee825246409..0bbf1df6a8d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 30 20:43:45 UTC 2015
+# Thu Dec 31 00:35:38 UTC 2015
pkgbase = python2-django-assets
pkgdesc = Asset management for Django, to compress and merge CSS and Javascript files
pkgver = 0.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/miracle2k//
arch = any
license = BSD
@@ -12,7 +12,11 @@ pkgbase = python2-django-assets
depends = python2-django
depends = python2-webassets
source = https://github.com/miracle2k//archive/0.11.tar.gz
+ source = https://github.com/miracle2k/django-assets/commit/9e7ab78fd1cea466a4811b9244b096a87d34c100.patch
+ source = https://github.com/miracle2k/django-assets/commit/d32a7d8ca59555e0d6f452cd18ccd6e01e3211f6.patch
md5sums = 97f7ce3ba6019d90865e0f4f6ac2c0b7
+ md5sums = d9852d3d38b52d2c6d23109e96fa2f7f
+ md5sums = 6ba2a668dff4fdff71cfa5f27432c2ae
pkgname = python2-django-assets
diff --git a/PKGBUILD b/PKGBUILD
index 3cddfbd07dab..47459e771706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,26 @@
pkgname=python2-django-assets
pkgver=0.11
-pkgrel=1
+pkgrel=2
pkgdesc="Asset management for Django, to compress and merge CSS and Javascript files"
arch=('any')
license=('BSD')
url="https://github.com/miracle2k/${pkgbase}/"
depends=('python2' 'python2-django' 'python2-webassets')
makedepends=('python2-setuptools')
-source=("https://github.com/miracle2k/${pkgbase}/archive/${pkgver}.tar.gz")
-md5sums=('97f7ce3ba6019d90865e0f4f6ac2c0b7')
+source=("https://github.com/miracle2k/${pkgbase}/archive/${pkgver}.tar.gz"
+ "https://github.com/miracle2k/django-assets/commit/9e7ab78fd1cea466a4811b9244b096a87d34c100.patch"
+ "https://github.com/miracle2k/django-assets/commit/d32a7d8ca59555e0d6f452cd18ccd6e01e3211f6.patch")
+md5sums=('97f7ce3ba6019d90865e0f4f6ac2c0b7'
+ 'd9852d3d38b52d2c6d23109e96fa2f7f'
+ '6ba2a668dff4fdff71cfa5f27432c2ae')
+
+prepare() {
+ cd "${srcdir}/django-assets-${pkgver}"
+
+ patch -Np1 < "${srcdir}/9e7ab78fd1cea466a4811b9244b096a87d34c100.patch"
+ patch -Np1 < "${srcdir}/d32a7d8ca59555e0d6f452cd18ccd6e01e3211f6.patch"
+}
package() {
cd "${srcdir}/django-assets-${pkgver}"