summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Ruhier2016-10-30 02:41:28 +0200
committerAnthony Ruhier2016-10-30 02:41:28 +0200
commit3bdaff40a05511d01a8f779d89381f463b7cd53f (patch)
treeb7c11e8a781057fd402d15a25bf0bfb29ff9be8b
downloadaur-3bdaff40a05511d01a8f779d89381f463b7cd53f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c2681b8fb18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-django-debug-toolbar-git
+ pkgdesc = A configurable set of panels that display various debug information about the current request/response.
+ pkgver = 1.6.r3.g3728860
+ pkgrel = 1
+ url = https://django-debug-toolbar.readthedocs.io/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = python2
+ depends = python2-django
+ provides = python2-django-debug-toolbar
+ conflicts = python2-django-debug-toolbar
+ source = git://github.com/django-debug-toolbar/django-debug-toolbar.git
+ md5sums = SKIP
+
+pkgname = python2-django-debug-toolbar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6b8424bb400
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Anthony25 <Anthony Ruhier>
+#
+# Maintainer: Kevin Maeder <kmaeder[AT]kevin-maeder[dot]de>
+
+pkgname=python2-django-debug-toolbar-git
+_gitname=django-debug-toolbar
+pkgver=1.6.r3.g3728860
+pkgrel=1
+pkgdesc="A configurable set of panels that display various debug information about the current request/response."
+arch=('i686' 'x86_64')
+url="https://django-debug-toolbar.readthedocs.io/"
+license=('BSD')
+depends=('python2' 'python2-django')
+conflicts=('python2-django-debug-toolbar')
+provides=('python2-django-debug-toolbar')
+makedepends=('git')
+source=('git://github.com/django-debug-toolbar/django-debug-toolbar.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ python2 setup.py install --root=${pkgdir} && \
+ install -D -m0644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+